Akismet not working

Topics: ASP.NET 2.0, Business Logic Layer
Feb 26, 2010 at 2:57 PM

Hey guys,

I've been using BlogEngine.NET since 1.5 and really like it. Excellent work!

I recently did an upgrade to 1.6 and I've been getting a lot of spam lately (saw the discussion about a new wave coming through) and wanted to get Akismet up and running to filter things out.

Here's the process I've taken and maybe somebody can point to an error I have.


1. I went to the akismet site and registered for a key. I used my generic Gmail account and not my "standard" e-mail address that is configured as the admin.

2. I got the e-mail and activated the key. I took that value and copied it down.

3. I went into the Extensions section and enabled the AkismetFilter. After enabled, I went into the configuration, entered my key and the address of my blog.

4. I then went into the comments section, checked the box to moderate comments, and selected the "Automatic" radio button.

5. I then went down to the custom filters, and changed the priorities so that Akismet has a priority of 1 and StopForumSpam has a priority of 2.

6. I saved everything up and waited. 

Shortly after another wave of spam came in and I had to delete them all (WONDERFUL new comment management by the way thank you!). I dug around a bit and found an older article on setting up the AkismetExtension and the documentation online indicated that I needed to use my WordPress API key as my Akismet filter key. So I went into my WordPress profile, grabbed the key, and just to make sure, I changed the website address in my profile to match my blog address in the AkismetFilter extension.

After updating these settings, there was still nothing working. Another wave came in shortly after. In both cases, the stats for the filters said they had processed 0 comments and in addition, I'm noticing that both the filter extensions are greyed out from me being to enable them or not.

Is there something I'm missing? Could it be that I need to change the e-mail address on my WordPress account (or maybe my admin profile here) to match?

Keep up the great work guys!

[:: Sean ::]

Feb 26, 2010 at 8:20 PM

It sounds like you've done everything right.  Although it's not part of BE by default, you might want to consider adding a captcha, like the re-captcha implementation Filip has created here.

Feb 26, 2010 at 9:01 PM

Thanks for the confirmation Ben. Now do you know, does it really matter if I use an Akismet or WordPress key for the plugin, or are they essentially the same thing?

I like the captcha idea too. I'm pulling up that link now. Thanks!


[:: Sean ::]

Feb 26, 2010 at 10:30 PM

Not sure why it is not working for you Sean, looks like you doing all right. You can double-check with this doc, just to make sure. If you have Akismet key from Wordpress it should work just fine.

Mar 1, 2010 at 11:13 PM

DillieO, you actually need to make sure you set Akismet to priority '2' and StopForumSpam to priority '1'.  If you don't do this then what will happen is StopForumSpam will re-approve the spam Akismet has found.  This is because the Akismet "fall through" is broken and so it continues to run the next spam filter even if it detects spam. I have documented and reported this as a bug already (you can look at the patch files to see what you need to change to fix it, but again you can just reverse the priorities so Akismet goes last)

Also Akismet is not perfect, I find it has about 80% accuracy at detecting spam, which is still way better than SFS which has about a 10% accuracy.

Mar 5, 2010 at 3:43 PM

Hey guys,

I think all is good. I was double and triple checking the settings and realized that all the spam posts I was getting was not triggering a "view entry" in my stat tracking program.

I'm thinking that maybe there was a remote publishing hack or something to that effect that was going into place, and not triggering akismet or the tracking code.

Thanks all for your help!

Jul 9, 2010 at 11:12 PM

I found this topic whilst having problems myself, so for future reference for anyone else...

I had all the settings set as above, except I had skipped the "Add to whitelist/blacklist..." settings.  Make sure these are NOT set to 0!  Mine were, and everything was being whitelisted straight away!