Postings only visible when I'm logged in

Feb 28, 2010 at 5:36 AM

I've got everything working wonderfully, except that I can't see my blog entries unless I'm logged in.

See here...

Notice the Month List says none.  If I log in, it shows my one blog entry (just one so far).

I'm looking through the settings to find some indication that you need to be authenticated to see the postings...but that seems to be an illogical notion for blogging system.


What am I missing?

Feb 28, 2010 at 5:46 AM

Okay, more details.

First, the "Month List" always shows None.  I can't make it show anything else.

Second, "Recent Posts" is also always blank.

Third, if I check my "About Me" page as "Make front page" then it does appear as the front page, both when I'm logged in and not.
But if I uncheck it, then...

  • I see my one blog post as my front page if I'm logged in
  • I see nothing but the widget-sidebar if I'm not logged in (effectively, the screen is 90% blank)

Feb 28, 2010 at 7:21 AM

Did you publish your post? Posts need to be published to be visible to unauthenticated users.  To see whether it is published or not, log in as an administrator, click "edit" on your post, and look at the checkbox at the bottom.

Feb 28, 2010 at 8:13 AM

I would concur.  Right now there doesn't appear to be any posts on your site.

If you have created a blog post (or posts), make sure they are published.  Once they are published, some of the widgets such as Month List, Recent Posts, etc will probably start displaying them.

Feb 28, 2010 at 2:30 PM

Sorry, I should have mentioned this last night.  Yes, the "publish" checkbox IS checked.

Still no posts, and the relevant widgets still say "None."

I keep thinking there's some configuration setting, to only allow authenticated visitors to see blog entries.  I've been up and down the Settings screen and others looking for some such, and can't find one.

Could this be a web.config thing?  Is there some other means of configuration I'm not thinking of?

Feb 28, 2010 at 5:06 PM

Okay, I've no explanation here, but it's working.

I fired up my browser this morning, and there it was, working perfectly.  I can think of nothing I did.  Perhaps it was some stray Session variable, or cookie, throwing things off.  The one thing I didn't try last night was shutting all my browsers down and trying again...or trying the blog from another computer altogether.

I'm good to go.  Thanks everyone!

Mar 1, 2010 at 12:55 AM
Edited Mar 1, 2010 at 12:56 AM

If you continue to have problems you might want to check your server time offset.  I had a similar problem that turned out to be that offset, meaning that my published posts would only show up several hours after I put them up.  Set it accordingly and I was up and running.

I forgot to mention that it is under Administration -> Settings and is the last item in Basic Settings.  Don't know if you needed all that, but there it is.

Mar 1, 2010 at 2:16 AM

You know, that could be part of it.  I did notice the time-setting was pretty far off of East Coast USA time, and thought I changed it.  I'll look again.

But for now it's working.