What should Syndication.axd displays?

Topics: ASP.NET 2.0, Business Logic Layer, Controls
Mar 11, 2010 at 3:08 PM

I run BE release 1.6 in ASP.Net development server in vs2008 and not publish into IIS yet.

I clicked Subscribe link, then the browser open page Syndication.axd,  but the system displays the following text:

<?xml version="1.0" encoding="utf-8"?>
<rss version="2.0" xmlns:blogChannel="http://backend.userland.com/blogChannelModule" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:pingback="http://madskills.com/public/xml/rss/module/pingback/" xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/" xmlns:wfw="http://wellformedweb.org/CommentAPI/" xmlns:slash="http://purl.org/rss/1.0/modules/slash/" xmlns:geo="http://www.w3.org/2003/01/geo/wgs84_pos#">
  <channel>
....

Is it okay? Why the system display the text and cannot interactive with the user?
Regards,
Richard
Mar 11, 2010 at 8:03 PM

I launched my blog about 4 weeks ago http://www.beatst.com/SoulCalculus and I've been having the same problem.  This only seems to occur with certain versions of the web browser.

There is another simple question that I have but can't answer.  My syndication service has since stopped but I don't know how to restart it.  Is this something I need to ask my web hosting company to do?

Oh so near, yet so far ...

 

Feb 15, 2011 at 10:39 PM

Has anyone found a solution to this problem as I am experiencing the same thing. I'm using BE 2.0 and when you click on the subscribe button the syndication.axd displays raw xml instead of the desired page.

Currently I am hosting BE on an IIS 6 server externally hosted, however it works fine on my dev server which is hosted on my companies intranet also running IIS 6.

I have Gzip enabled on the server in question too, although as far as I  am aware this doesnt compress .axd files.

Any feed back appreciated.

 

Thanks

Mar 1, 2011 at 11:40 AM
Edited Mar 1, 2011 at 11:40 AM

I'm getting this problem, but only with Google Chrome 

Firefox, IE8, Safari & Opera all display the page correctly.

This does appear to be a problem specific to BlogEngine though. The Dilbert cartoon syndication page (http://feeds.dilbert.com/DilbertDailyStrip) displays correctly in Chrome.

The main difference, that I can see, is the content type of the page. The Dilbert page has a ContentType of

Content-Type: text/xml; charset=UTF-8

while the BlogEngine syndication page has a content type of

Content-Type: application/rss+xml

Even the Syndication page on http://www.dotnetblogengine.net/syndication.axd has the same problem, so it's not just our setups causing this!

Anyone with any ideas?

Coordinator
Mar 1, 2011 at 5:26 PM
cyberspy wrote:

I'm getting this problem, but only with Google Chrome 

Firefox, IE8, Safari & Opera all display the page correctly.

This does appear to be a problem specific to BlogEngine though. The Dilbert cartoon syndication page (http://feeds.dilbert.com/DilbertDailyStrip) displays correctly in Chrome.

The main difference, that I can see, is the content type of the page. The Dilbert page has a ContentType of

Content-Type: text/xml; charset=UTF-8

while the BlogEngine syndication page has a content type of

Content-Type: application/rss+xml

Even the Syndication page on http://www.dotnetblogengine.net/syndication.axd has the same problem, so it's not just our setups causing this!

Anyone with any ideas?


Take a look at this post - you will probably run into different issues switching to text/xml format.

Mar 1, 2011 at 7:29 PM
Edited Mar 1, 2011 at 7:29 PM

> I'm getting this problem, but only with Google Chrome
> Firefox, IE8, Safari & Opera all display the page correctly.

If you install Chrome RSS Subscription Extension,  :

https://chrome.google.com/extensions/detail/nlbjncdgjeocebhnmkbbbdekmmmcbfjd

Chrome will detect your feed and you will see syndication.axd the way you expect.
Alternatively, you can provide your syndication.axd to Google Feeds, former FeedBurner