Problem 1.6.1

Apr 30, 2010 at 1:53 AM

Hello, I migrated from version 1.5 to 1.6.1, I download the files, and played on ftp, updated the database, and the following error appears.

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0117: 'ExtensionManager' does not contain a definition for 'GetExtension'

Source Error:

Line 77:             get
Line 78:             {
Line 79:                 ManagedExtension captchaExtension = ExtensionManager.GetExtension("Recaptcha");
Line 80:                 return captchaExtension.Enabled;
Line 81:             }

Source File: e:\home\marcioalth1\web\App_Code\Extensions\Recaptcha\RecaptchaControl.cs    Line: 79

Apr 30, 2010 at 3:49 AM

Are you using the BlogEngine.Core.dll file that comes with BE 1.6.1?  It would go into the BIN directory, and replace the old one from BE 1.5.

When upgrading from 1.5, you'll want to delete the entire ExtensionManager sub-folder under App_Code.  See here.