This project is read-only.

Non-Blog Pages within Same Project/App?

Jul 3, 2010 at 11:05 PM

What happens if I want to build an ASPX/CS page inside the same Project/Application which is running BlogEngine.NET, but have that page not inherit any of the styles, or other globally set stuff? I need to create some pages that will benefit from the same Session and other Application features, but will be completely blank/standard ASPX page configurations. Can I do this? How?

When I create a completely new ASPX page in the Project, it *looks* completely "plain" (doesn't use the theme master pages, etc.), but when i run it, the page gets some CSS, etc. and I don't know where that's coming from.

Help MUCH appreciated!

Jul 4, 2010 at 1:00 AM

Is that .ASPX page using the BlogEngine.NET MasterPage still? If so it's going to inherit all of the CSS / AJAX / JavaScript stuff that comes with BE.NET.

Jul 4, 2010 at 3:47 PM
No, see that's the part that's comfusing. I created this ASPX page all by itself in a brand new directory. I doesn't reference *any* Master pages... But when I run it, it does two strange things: 1. It seems to get a bunch of style stuff from the theme EVEN THOUGH it is not attached to any master page. 2. I don't get to see the contents of my page at all because it presents an error that says: "Ooops! An unexpected error has occurred. This one's down to me! Please accept my apologies for this - I'll see to it that the developer responsible for this happening is given 20 lashes (but only after he or she has fixed this problem). So I'm thinking that there are settings inside web.config of BlogEngine.NET that set up control over the ENTIRE site, insert stuff into all pages, and also raise errors when a page doesn't conform to the theme somehow? I'd love any help anyone can provide! Thanks. Alex
Jul 4, 2010 at 4:02 PM

Oh... I believe I must hang my head in shame :). Turns out that the reason why this was happening was that the page I was trying to load was throwing an exception and BE.N was redirecting me to an error page. I hadn't noticed that. Apologies. All is well!