Incompatibility with 4.0?

Aug 24, 2010 at 3:27 PM

Hi guys

I have just update my remote server to 4.0 but I have not changed any exisiting sites on the server,
most of which use 3.5

All the sites on the server seem happy with this upgrade without mods, but does anyone know of any issues
with blogengine (which uses 2.0)? 

I had assumed that upgrading to 4.0 should be no issue as it is incremental not revolutionary, but the blog is
now throwing an exception error:

Exception information:
    Exception type: TypeInitializationException
    Exception message: The type initializer for 'BlogEngine.Core.Web.HttpModules.ReferrerModule' threw an exception.

I can't be sure that the upgrade and this error are related, but I have not made any other changes.

Please help!



Aug 24, 2010 at 4:09 PM

I am replying to myself, in case someone needs this answer...

I went browsing round the IIS settings for the blog, and decided to change the application pool to 'asp.net2.0'
instead of the 'default app pool' where it had been running with 3.5 framework previously, and once again the,
blog is working!


Sep 1, 2010 at 4:26 AM

Can you tell me where I can find this line of code? I am trying out BE and just had it installed on my host server which is running ASP.NET 4.0. I am getting an error trying to add a new entry into the blog. I get a 500 Internal Server error. I think this is related. Thanks.