Blogengine making Server 2008 R2 to crash

Aug 31, 2010 at 10:43 AM
Edited Aug 31, 2010 at 10:46 AM


I'm using as CMS for my News section and for some reason when adding new Posts the Blogengine crashes the Server 2008 R2.

This only happens if I coppy and paste text from a word document. If I Use Raw Editor, copy the text from a word document and than use WYSIWYG editor to format text it never crashes. I don't even have to save the post to crash the server. All I have to do is - Copy text from Word Document to Blogengine editor when Use Raw Editor checkbox is unchecked and than check that checkbox.

Is it common problem? Any way to resolve it?




Sep 1, 2010 at 10:02 AM

You could try adding the "paste" plugin to tinyMCE.  Documentation is here.

The file to edit is tinyMCE.ascx in the admin folder.  There's already an existing "plugins" line of code.  So you could just add "paste" to the end of the comma delimited list of plug-ins.

Then you may need to add the "pasteword" toolbar icon (documented at the same link) to the toolbar icons already being specified at the end of "theme_advanced_buttons1".

I'm not sure if just adding the "paste" plugin is enough, or if after adding the plugin and toolbar icon, you may need to click the new Word toolbar icon to paste your Word contents into the dialog window that opens up.

I haven't personally run into this problem, so I don't think I can test it on my end.  But maybe see if this plugin and toolbar icon help.

Sep 1, 2010 at 10:10 AM

One other thing .. is this is a new blog installation?  If you happen to have the site in a .NET 4.0 application pool, you may need to either change the application pool to 2.0, or add the "requestValidationMode" to the <httpRuntime> element in your web.config file ... as brought up here and here.