[Solved] Server 20008 R2 - X64: 500 - Internal server error

Topics: ASP.NET 2.0
Sep 13, 2010 at 7:15 PM

I moved my blog (BlogEngine 1.6.0.0) to a Server 2008 R2 X64 install. All seemed to work well, but when I wanted to add a new entry and clicked the 'Save post' button I got this error:

 

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.
This one's down to me! Please accept my apologies for this - I'll see to it that the developer responsible for this happening is given 20 lashes (but only after he or she has fixed this problem).
Error Details:

Url : http://www.rc-international.info/Blog/admin/Pages/Add_entry.aspx

Raw Url : /Blog/admin/Pages/Add_entry.aspx

Message : Exception of type 'System.Web.HttpUnhandledException' was thrown.

Source : System.Web

StackTrace : at System.Web.UI.Page.HandleError(Exception e)

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest()

at System.Web.UI.Page.ProcessRequest(HttpContext context)

at ASP.admin_pages_add_entry_aspx.ProcessRequest(HttpContext context)

at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

TargetSite : Boolean HandleError(System.Exception)

Message : Access to the path 'C:\inetpub\wwwroot\Webhosting\www.rc-international.info\BlogEngine\App_Data\posts\041e93fb-d84e-4faf-95b2-a35e06da44c5.xml' is denied.

 

This is the first part of the error, if more is needed to resolve this problem I am happy to post it here.

My website is in an ASP.NET 2.0 application pool and the Blog itself is in a Classic ASP.NET (2.0) application pool. This is how I had it on the previous server.

Any suggestions where to look at to solve this?

Thank you very much in advance!

Coordinator
Sep 13, 2010 at 8:10 PM
CrashingDutchman wrote:

I moved my blog (BlogEngine 1.6.0.0) to a Server 2008 R2 X64 install. All seemed to work well, but when I wanted to add a new entry and clicked the 'Save post' button I got this error:

Message : Access to the path 'C:\inetpub\wwwroot\Webhosting\www.rc-international.info\BlogEngine\App_Data\posts\041e93fb-d84e-4faf-95b2-a35e06da44c5.xml' is denied.

Looks like identity used by your application pool does not have write permissions on app_data folder. Check out in IIS what user running this pool and verify write permissions on the folder. (this might help)

Sep 13, 2010 at 9:41 PM
rtur wrote:
CrashingDutchman wrote:

I moved my blog (BlogEngine 1.6.0.0) to a Server 2008 R2 X64 install. All seemed to work well, but when I wanted to add a new entry and clicked the 'Save post' button I got this error:

Message : Access to the path 'C:\inetpub\wwwroot\Webhosting\www.rc-international.info\BlogEngine\App_Data\posts\041e93fb-d84e-4faf-95b2-a35e06da44c5.xml' is denied.

Looks like identity used by your application pool does not have write permissions on app_data folder. Check out in IIS what user running this pool and verify write permissions on the folder. (this might help)

Wow, I would never have found that without the information in your link! Thank you!