Hiding my email from the RSS feed

Topics: Business Logic Layer
Mar 3, 2008 at 12:21 AM
I noticed that my email is part of the author in the RSS feed:
<author>morten.nospam@nospam.mydomain.com (Morten)</author>
While the email is slightly changed by putting the nospam in there, it's not very hard to figure that out and grab it. This blogengine is now so big, that most spammers probably already figured it out, and is starting to grab our emails from all blogengine sites.
I just want my name in there and nothing else.

Where can I change this? (I don't mind changing the code to do this)
Mar 3, 2008 at 8:58 AM
You'd need to change the code in the BlogEngine.Core and recompile the .DLL.

The file is \Core\SyndicationGenerator.cs (line 531 in BE.NET or else just search for 'spam')

writer.WriteElementString("author", BlogSettings.Instance.Email.Replace("@", ".nospam@nospam.") + " (" + publishable.Author + ")");

Change that into:

writer.WriteElementString("author", publishable.Author);

And only your author's name ends up in the feed, no email addresses.

Does that help?
Mar 3, 2008 at 9:02 AM
In addition: I'd like to ask the BE.NET development team to change this email address behavior in the 1.4 release.

My suggestion to the team is to either remove that behavior completely or at least offer a disable option.
Frankly, it surprised me that all of a sudden BE.NET published my email address (despite the nospam@ addition).

My two cents,
Mar 7, 2008 at 5:00 PM
SharpGIS, could you use my pointer?
Mar 8, 2008 at 2:02 PM
RSS feeds without an email are invalid according to the spec. This may not be a problem for you, but for me at least it is.

In fact, for me I'm very annoyed that the nospam is inserted automatically---that's just tacky. Call me foolish, but I'm not afraid to publish my email on my own website.

I strongly suggest that BE.NET add a setting for what you want the RSS feed email to be. If it's left as an empty string, then just use the author name. Otherwise, use the normal format. People can customize with their own anti-spam "protection," or lack thereof, as desired.
Mar 8, 2008 at 3:38 PM
Just saying BE.NET jumped from 'author name only' to the email address + @nospam + (Author name) without any notification.
Domenic, I agree with you on all your points:

  • Yes, 'nospam' looks pretty tacky
  • Yes, it should comply with the RSS specs (I hadn't a clue it was though)

As for email address publication, well, I publish mine too - it's just I would like to decide which address is displayed (which may differ from the default in BE.NET admin). So yes, at least the blog owner/author should have the choice.

Thank you Dominic for sharing your thoughts.
Aug 10, 2008 at 11:42 AM
Go vote... http://www.codeplex.com/blogengine/WorkItem/View.aspx?WorkItemId=7262
Sep 22, 2008 at 8:45 PM

I am really trying to fix this but not having much luck. The fix above doesnt work for me, I guess since I have version 1.45, there isnt a \core\ folder or that file. I need to change the nospam address, to noreply@domain.com. Does the version I have, have a setting where I can change this, because I looked but did not find. Any help would be greatly appreciated.

Thanks ....
Dec 22, 2008 at 11:01 PM
Edited Dec 22, 2008 at 11:01 PM
Supposed it was fixed (issue #7262), but if that's the case, it seems to be broken again.  To get to the core folder you need the BE source.  I'd personally rather not have to mess with recompiling the source :)
Dec 23, 2008 at 2:30 AM
The nospam@nospam was removed in