Can't view content without logging in..

Topics: ASP.NET 2.0, Controls
Nov 18, 2010 at 9:57 AM
Edited Nov 18, 2010 at 3:08 PM

Hi all,

I'm new to Blog Engine, moved from WP which was very slow on my godaddy windows hosting.Although think BE is a great blog tool I have a few issues I can't seem to fix:

Should mention I have a deluxe hosting with multiple domains and using IIS7."mydomain" is the folder where BE is installed.

1. When accessing I get redirected to [..] which asks me to login. Actually I can't view any page and articles I created without logging in. So anyone who visits won't see any content without an account.

2. When I hit I redirected to - which is not such a big issue if everythign else would work. I already saw the article about this but I am a designer and don't have coding experience.

I appreciate any help/advice on this.

Thanks in advance,


Nov 18, 2010 at 12:08 PM

Can someone please reply to this? I can post a screenshot if helps..

Nov 18, 2010 at 1:13 PM
Edited Oct 24, 2011 at 9:24 PM

Is this your BlogEngine version? BlogEngine.NET


Did you do a Once Click install with Go Daddy or did you uploaded the files yourself?


Are you having XML as the Database or SQL?


Seems like an URL redirect problem.


I looked at your site it seems to be more than a login issue.  Looks like none of the css is working.


Java Blog

Nov 18, 2010 at 1:41 PM

Might be a Sub Directory Issue.


Read this Post:



Nov 18, 2010 at 3:08 PM

Thanks for your help, I appreciate it but there are too many issues here  - that require a coder to solve, which I'm not. I switched back to wordpress..