Email test fail on Blogengine.net

Topics: ASP.NET 2.0
Nov 26, 2010 at 3:48 PM

Trying to test Blogengine.net...

I was able to set the blog and it works. However when I try to test email (registered with Google apps) I receive following error:

Could not connect - Request for the permission of type 'System.Net.Mail.SmtpPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Any clue where should I look?

Nov 26, 2010 at 4:39 PM

problem solved  - got help from another forum.

Had to make following changes in web.config

<configuration> 
  <system.web> 
    <trust level="Full" /> 
  </system.web> 
</configuration> 

 

Coordinator
Nov 26, 2010 at 7:45 PM

As an FYI, that should only be necessary if you're specifying a port other than 25.  A lot of people are using shared webhosting where their website is in a medium trust environment, and setting the trust level to Full, like you did, isn't an option.  In these cases, people just need to use port 25 -- which is the only allowed port under medium trust.