Check Spell in Creating New Post

Topics: ASP.NET 2.0, Controls
Nov 26, 2010 at 7:24 PM

Hi,

Is there a way to enable Spell Check while creating a new post?

Also, in the "TextBox" extension, there is no way to upload an image. How can I do so?

 

Thank you

Regards

Coordinator
Nov 26, 2010 at 7:43 PM

For uploading an image, you're right that you cannot upload an image from the TextBox widget.  What you can do, as a workaround, is go to the control panel to Write a New Post, and upload an image there.  When you do that, the URL will be put into the WYSIWYG editor.  It'll probably be the actual image that you see, but if you click on the "HTML" toolbar icon (or View Raw HTML checkbox), then you can get the URL to the image.  It'll be something like image.axd?picture=....  You can then copy that URL and use it in the TextBox widget.  You don't need to save the new Post.  Just leave without saving ... the image you uploaded will stay on disk.  To put the image you uploaded into the TextBox widget, you might need to click the "HTML" toolbar icon in the TextBox WYSIWYG editor, and manually create the IMG tag.

Spell Check ... are you using Firefox?  If so, I believe that by default, tinyMCE (the WYSIWYG editor), disables the Firefox built-in spell checker.  But this can be enabled.  In the tinyMCE options, if you set "gecko_spellcheck" to "true", it'll display.  I think I'll make this change in BE since there's no real reason to have the built-in spell checker disabled.  To set this option, there's 2 places to do it (one place for the control panel WYSIWYG editors, and another place for the TextBox widget WYSIWYG editor).

For the TextBox widget, the file to change to enable Firefox spell checking is in widgets\TextBox\edit.ascx.  In there is a bunch of tinyMCE settings.  You would want to add this setting, where all the other settings are (theme_advanced_buttons1, theme_advanced_blockformats, etc).

gecko_spellcheck: true,

The 2nd place to make this change is in admin\tinyMCE.ascx.

Nov 26, 2010 at 8:00 PM

Thanks Ben! I will do those changes and get back.

 

I am new to BlogEngine, I am so interested to explore it details and start adding more components. Any guide lines on how to drive inside BlogEngine?

 

Thanks

Coordinator
Nov 26, 2010 at 11:24 PM

There's the Videos page, and the Documentation.  These may not be extremely helpful, but might help for some areas.

You can ask questions here as well.  Probably you'll get the hang of things after working with BE for a while.

Nov 27, 2010 at 5:49 AM

Thanks Ben.

Nov 27, 2010 at 8:00 AM

Hi Ben,

I did the changes. Now inside FireFox, I can see wrongly spelled words underlined. However, the context menu is that of  tinyMCE and not FireFox. Maybe I can disable tinyMCE context-menu and then FireFox's menu show up.

I have another question please related to uploading images. I went to a new post, clicked on "Insert Image". I chose my image, then click submit. Automatically, I am redirected to Login page (even when I am logged in).

Do you think its a security issue? I should give App_Data read/write?

Thanks

Coordinator
Nov 27, 2010 at 8:45 AM

You're right about the tinyMCE context menu appearing in place of Firefox's spelling suggestions when right-clicking on a misspelled word.  You could remove "contextmenu" from the list of plugins -- in the same 2 files you modified already.  But I found a nifty trick so you can keep the Firefox spell checker and keep the tinyMCE context menu.  When right-clicking on a misspelled word, hold down the Control key.  This will disable the tinyMCE context menu so Firefox's normal context menu appears.

Hmm.. not sure about being redirected to the login page.  Which version of BE are you using?  You definitely want to make sure Write permissions are set on the App_Data folder since that's where the images & files get saved.  Normally if Write permissions are not enabled, when trying to upload, you would (I think) get an error, rather than being redirected to the login page.  You could also try uploading a File, instead of an Image.  Both will accomplish getting a file onto the server.  But you might have the same problem with that if you're having problems with image uploading.  If you're using the default XML storage, you can check if you can save a new Post, or save Settings, etc, since these changes also get saved to App_Data (so you would be checking to see if you can save something other than an image).  You could also try seeing if you can upload an image on the Pages tab.  You'd probably get the same result ... running out of ideas!  A better idea might come to me.

Nov 27, 2010 at 8:56 AM

Hi Ben,

I am using SQL Server as storage. I was able to add posts!I will double check with my hosting company and make sure they have Write access on App_Data.

Trick worked perfect ;) Thanks.

Nov 30, 2010 at 11:28 AM

Hi Ben,

I added Network Service full permission on the App_Data still couldnt be able to upload an image.

I tried with two users: An editor and admin.

Is there a log I can look at?

Thanks

Coordinator
Nov 30, 2010 at 8:10 PM

What version of BE are you using?  Does the same thing happen when you upload a file?  What URL is in the address bar when you are redirected to the login page?

In the Advanced Settings section, there is an "Enable Error Logging" checkbox you can check.  Only certain things are logged, so not sure if this situation will be logged (probably not, but it might).  The log will be saved in the App_Data folder -- logger.txt.

Dec 1, 2010 at 6:14 AM

Hi Ben,

I am using BE 1.6.2.55.

This is the URL I am being redirected to: http://mydomain/Account/login.aspx?ReturnUrl=%2fadmin%2fPosts%2fAdd_entry.aspx%3fid%3da4c42f94-97e0-42f1-89bb-adcb26e2b1ec&id=a4c42f94-97e0-42f1-89bb-adcb26e2b1ec

I have IUSR, ASPNET, and NETWORK SERVICE Full rights on App_data.

 

Regards

Bilal

Dec 1, 2010 at 6:40 AM

Hi Ben,

I figured out the problem.

I had my DefaultAppPool configured to run with ApplicationPoolIdentity on Windows Server 2008 R2 - IIS 7.0.

I changed the account to Network Service and now everything seems to be working fine.

Any security breach in that?

Regards

Bilal

Coordinator
Dec 1, 2010 at 6:55 AM

Very glad you found that out -- good detective work.

Nothing wrong with that.  I've seen that too in IIS7 where the default account is ApplicationPoolIdentity.  I usually switch mine to Network Service too.  Mainly because I'm not sure what account to assign file permissions to when it's ApplicationPoolIdentity ... and similarly for DB connections, I often used Windows Authentication and I know how to give DB access to Network Service, but not sure about ApplicationPoolIdentity.

There's many services on Windows that run under Network Service.  There's no problems I'm aware of running the IIS app pool under that as well.

Dec 1, 2010 at 7:00 AM

Thanks Ben for your help.

Have a look at this post that shows how to "concretitize" the ApplicationPoolIdentity:

http://serverfault.com/questions/81165/how-to-assign-permissions-to-applicationpoolidentity-account

 

Regards

Bilal