This project is read-only.

Unable to upload videos in 2.0 RC

Topics: ASP.NET 2.0
Dec 12, 2010 at 6:17 PM


I am unable to upload video files to posts when using the 2.0 RC.

I click the upload video button on the post editor, and get the file upload dialog.  I then select my file (tried several different .wmv files), and click upload.  At that point I get an error saying (in Google Chrome):

This web page is not available.

The web page at http://localhost:50903/admin/Posts/Add_entry.aspx?id=73dd397b-71d3-44e0-8738-66855fecbd9d might be temporarily down or it may have moved permanently to a new web address.

 More information on this error

Below is the original error message

Error 101 (net::ERR_CONNECTION_RESET): Unknown error.


Not sure if it is any help, but I ran the debugger on my project while trying to perform the above steps.  I got the following error:

Call stack location:

BlogEngine.Core.DLL!BlogEngine.Core.Web.HttpModules.CompressionModule.ContextPostReleaseRequestState(object sender, System.EventArgs e) Line 127 + 0x3f bytes

Source file information:

Locating source for 'E:\Projects\BlogEngine-HG-7\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs'. Checksum: MD5 {70 84 45 a1 1f b5 bf 41 d4 67 e4 d7 52 29 f0 12}The file 'E:\Projects\BlogEngine-HG-7\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs' does not exist.Looking in script documents for 'E:\Projects\BlogEngine-HG-7\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs'...Looking in the projects for 'E:\Projects\BlogEngine-HG-7\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs'.The file was not found in a project.Looking in directory 'C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\vc7\atlmfc'...Looking in directory 'C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\vc7\crt'...The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: E:\Projects\BlogEngine-HG-7\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs.The debugger could not locate the source file 'E:\Projects\BlogEngine-HG-7\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs'.

Any idea what could be causing this?