Akismet stopped working after upgrade to 2.0

Topics: Business Logic Layer
Jan 4, 2011 at 6:55 AM
Edited Jan 4, 2011 at 6:56 AM

I had been using v1.5 for nearly a year and have been using Akismet to filter out spam comments. The akismet filter has been working nearly flawlessly until I recently upgraded to V2.0. I have confirmed that my API key is still in the config, but ever since my upgrade I receive several spam comments every day which is quite annoying. Is this a known issue?

Coordinator
Jan 4, 2011 at 7:45 AM

If your API key is in there, it's probably working, but the order of the checks in v2.0 may be different causing different results.

One thing to check is in the control panel.  Settings -> Comments Rules & Filters.  At the bottom where Anti-Spam services is, first see if there are numbers for the Akismet filter -- Checked, Spam, Mistakes.  See if these values have numbers, and if they are increasing as new comments come in.

The other thing to check are the settings above that on the same page.  "Add to white list if at least", you could try setting to 0.

Also, check to see if these spam comments you see coming in are actually "approved" or "pending" or "spam".  In BE 1.6, would the spam comments get automatically deleted?  It's possible these spam comments are coming in as "pending" or "spam", but are not "approved".

Jan 4, 2011 at 2:07 PM

The Akismet numbers are all 0 on the Rules & Filters page. It’s priority is below the StopForumSpam filter, which does have numbers. I had read in another discussion that Akismet should be below StopForumSpam, but I’m going to try to move Akismet back to 1 and see if that changes anything.

Based on your suggestion, I am changing the White List rule from 1 to 0. I believe I had read somewhere that it should be set to at least 1. We’ll see if that changes anything.

In 1.5, the spam was automatically deleted. Now comments marked as spam by StopForumSpam remain and I have to manually delete.

From: BenAmada [email removed]
Sent: Monday, January 03, 2011 11:45 PM
To: Matt Wrock
Subject: Re: Akismet stopped working after upgrade to 2.0 [blogengine:240356]

From: BenAmada

If your API key is in there, it's probably working, but the order of the checks in v2.0 may be different causing different results.

One thing to check is in the control panel. Settings -> Comments Rules & Filters. At the bottom where Anti-Spam services is, first see if there are numbers for the Akismet filter -- Checked, Spam, Mistakes. See if these values have numbers, and if they are increasing as new comments come in.

The other thing to check are the settings above that on the same page. "Add to white list if at least", you could try setting to 0.

Also, check to see if these spam comments you see coming in are actually "approved" or "pending" or "spam". In BE 1.6, would the spam comments get automatically deleted? It's possible these spam comments are coming in as "pending" or "spam", but are not "approved".

Coordinator
Jan 5, 2011 at 8:07 AM

Although it was probably nice that the spam was automatically deleted before (and this might not be an option now), I think the important thing is that the spam is correctly identified as spam -- assuming that this part is working (the filters are setup correctly so they are checking and correctly marking spam as spam).

Then, it's mostly effortless to go into the Comments area in the control panel once in a while, and just delete all the spam at once.

I'll check a blog that I think is using Akismet w/ BE 2.0 to see if the counters are going up.