This project is read-only.

BE 2.0 Not loading Extensions

Topics: Controls
Jan 10, 2011 at 3:26 PM

I have recently upgraded to BE 2.0 from 1.61, following all the upgrade instructions. Now I have an issue where the extensions are not being loaded by the blog at all. Ther are not functioning nor are they available in the Extension Admin page. Any thoughts as to why this is occurring?

Jan 10, 2011 at 3:37 PM

Are you using Xml or Sql provider?

Jan 10, 2011 at 3:38 PM

Default XML.

Jan 10, 2011 at 3:53 PM

Could be security issue. Will you able to try to run it with full privileges?

Jan 10, 2011 at 4:07 PM

I ran it with full privileges and this what I got:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 1/10/2011 10:58:03 AM
Event time (UTC): 1/10/2011 3:58:03 PM
Event ID: 673433c7537e45b59c9875aadc4f18bf
Event sequence: 2
Event occurrence: 1
Event detail code: 0
Application information:
    Trust level: Full
    Application Virtual Path: /
    Application Path: D:\XXXXXXXX\XXXXXXXX\
    Machine name: XXXXXXXX
Process information:
    Process ID: 4052
    Process name: w3wp.exe
Exception information:
    Exception type: XmlException
    Exception message: Unexpected end of file has occurred. The following elements are not closed: Parameters, Settings, ManagedExtension. Line 1395, position 5.
Request information:
    Request URL:
    Request path: /Default.aspx
    User host address:
    Is authenticated: False
    Authentication Type: 
    Thread account name: NT AUTHORITY\NETWORK SERVICE
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
   at System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res, String arg)
   at System.Xml.XmlTextReaderImpl.ThrowUnclosedElements()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlTextReader.Read()
   at System.Xml.XmlReader.ReadElementString()
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderManagedExtension.Read3_ExtensionParameter(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderManagedExtension.Read4_ExtensionSettings(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderManagedExtension.Read5_ManagedExtension(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderManagedExtension.Read6_ManagedExtension()

Jan 10, 2011 at 5:51 PM

Looks like corrupted XML file for one of the extensions. If possible, remove all from app_data/datastore/extensions and recycle application, it will re-generate default XML data files. If this works, add back removed XML files one by one until you hit that error again, then you found corrupted data.

Jan 10, 2011 at 6:38 PM

Good call rtur, that fixed it.