This project is read-only.

Works in Firefox but not in Internet Explorer

Jan 14, 2011 at 11:02 PM

HI Guys,

I'm stumped here. I run a blog over at and for the life of me I can't figure out why it displays normally in firefox but when I try to view it in Internet Explorer it doesn't work. I just get a little bit of text and that's all. I've tried turning off the compression and everything. I've tried reloading it. I can get the default to show up but when I try and transfer my data over I get the default BlogEngine.Net post and none of my posts show up. Any idea's?  Thanks.

Jan 14, 2011 at 11:08 PM

What version of IIS and .NET Framework are you using?

Jan 14, 2011 at 11:17 PM

The sysntax generated by your blog has errors.  It looks like Firefox is more tolerant to those errors.

Let me take a look.


Jan 14, 2011 at 11:29 PM
neuromancer wrote:

The sysntax generated by your blog has errors.  It looks like Firefox is more tolerant to those errors.

there a syntax error around WebResource.axd, so it's likely that '<label for="ctl00_cphAdmin_cbCompressWebResource">Compress WebResource.axd' has something to do with it.</label>

You mentioned you have tried to uncheck it, perhaps you also need to clear the cache.


Jan 14, 2011 at 11:40 PM
Edited Jan 14, 2011 at 11:42 PM

Compress WebResource.axd is unchecked. so is Enable HTTP compression.

I am running Asp 4.0 and I belive I'm running ISS 7. I run it on if that helps. Thanks for helping.


When you mean clear the cache. Do you mean on my browser or on the site? because I don't think blogengine has a cache area on site does it?

Jan 14, 2011 at 11:55 PM

I mean BlogEngine cache. Make a meaningless change to web.config file, like add a apace or a comment. It will force recompilation and reinitialization clearng the cache.

Jan 15, 2011 at 12:51 AM
Edited Jan 15, 2011 at 1:07 AM

Is there an easy way to clear the cache or is the only way to create a button like he does here:


I tried to clear the cache by putting this line in the indigo theme site.master in the page load procedure

string ConfigPath = HttpContext.Current.Request.PhysicalApplicationPath + "\\web.config";
System.IO.File.SetLastWriteTimeUtc(ConfigPath, DateTime.UtcNow);

still didn't work. I also tried this in the page load section:
still no dice.
Jan 15, 2011 at 7:03 AM

Taking a quick look, it looks like you added your own <meta> description tag?   There's a missing quotation mark at the end:

<meta name="description" content="Provides updates to the user for LetsTrend.
Gives Instructions on how to use LetsTrend. Talks about different stock tests
that are performed. Gives updates on future functions for the site. />

Not sure if this is the cause of your problems, but appears to be a problem that should be fixed.

It also looks like the ASP.NET WebResource.axd is failing for some reason.

Are you using the ASP.NET 4.0 web.config file that is included with BE in the /setup folder?

Have you made any customizations to the web.config file or the site?  Are there any other applications running on the same website, or just BE?

Jan 15, 2011 at 11:17 AM

If you running on ASP.NET 4.0 Application Pool, try to switch to ASP.NET 4.0 Classic.

We have seen issues while using Integrated Pipeline 

Jan 15, 2011 at 4:35 PM

I've actually noticed a few things about the posts and my theme modifications. When I write the posts I use word and then I cut and past them into the blog. The formatting that word does is bad. So I had to go through my posts and delete all the formatting that word did. Thanks for your help guys.