Downloading Themes

Topics: Themes
Feb 8, 2011 at 8:34 AM

How does one get a downloaded theme to work?
In "Basic Settings," under Theme, I used the download, found a theme I liked, and it downloaded to my computer (instead of directly into the appropriate place in the BE2 app--as WordPress would have done). I finally figured out to get the new Theme Folder  as a subfolder in BE2 Themes, where  I found the Standard, Mobile and Indigo subfolders, too. I did this on VisualStudio 2010 (VS) by dragging the extracted new theme folder on my computer into the Themes Folder on the Solutions Explorer panel of VS. It took fine.

The first sign of trouble was when I ran debug on VS, and it was stuck.  I uploaded the new folder to the webserver; went back to BE2 control Panel / Setting / Themes; there I actually saw the new Theme listed, but when I tried to preview it, I got an error.

Could someone please tell me what I need to do to get it corrected? BTW, the new Theme is "MarketPlace1-0".

Thanks.

 

Feb 8, 2011 at 9:45 AM

Perhaps the theme you downloaded does not support BE 2.0, have you tried the three themes that come with BE, if they work ok then I would download another one, perhaps  this one that is updated for BE 2.0 and see if it works.

http://rtur.net/blog/file.axd?file=2010%2f9%2fBoldy4.zip

Feb 8, 2011 at 10:55 PM

You are right; that theme must not support BE2.
I downloaded the theme you recommended. The only problem is that the Blog  Name under  Basic Setting does not get through, so the site does not have the assigned name when viewed.

Thanks for the pointer.

Feb 8, 2011 at 11:58 PM

That is because he is using a custom logo in place of the Blog name code.  Check in the master page of one of the other themes and you should be able to setup this code in the site.master.

 

 <div id="header">
    <h1><a href="<%=Utils.AbsoluteWebRoot %>"><%=BlogSettings.Instance.Name %></a></h1>
    <p class="description"><%=BlogSettings.Instance.Description %></p>
  </div>