Problem upgrading from 1.6 to 2.0

Feb 8, 2011 at 5:14 PM

I installed a version of 2.0 on my localhost. I upgraded my database from 1.6 to 2.0 and changed the connection string to my upgraded database.

When i load my blog I get a page full of characters like this : V��j�ҧ_��j�����

Does anybody have any idea what the problem could be?

 

 

 

 

 

Feb 8, 2011 at 8:53 PM

Try the standard theme by adding "?theme=standard" at the end of the http://yourpath.  Most likely the theme you are using is not compatible with 2.0.

Feb 9, 2011 at 7:11 PM
Edited Feb 9, 2011 at 7:13 PM

I didn't change the theme. This is a new 2.0 installation. The only thing I did was upgrade my database using the script provided and changed the connection string to my upgraded db.

Feb 9, 2011 at 7:15 PM

Are you sure you are using the correct config.sys for the ASP.net version you are using?

Feb 9, 2011 at 7:28 PM

Not sure what you mean by the config.sys? Do you mean web.config? If so, yes I'm using the correct version, 3.5, the framework I'm targeting.

I created the "demo" database on the same instance of sql server as my old/upgraded database, so same connection string except for db name and it works fine. But when I use my old db I have this problem. Thought maybe it had something to do with the db collation, but both are set to Latin1_General_CS_AS.