BE on Surftown

Topics: ASP.NET 2.0, Business Logic Layer, Controls
Mar 16, 2011 at 8:58 AM


I'm running BE ( on a Surftown webhotel. The server is running IIS 7, ASP.NET 4.0 in Integrated Mode. I have been told that the server is running full trust under impersonation. If you visit the link, you will see the error (Utils.LoadExtensions() in Global.asax). It is not possible for me to change the permissions on the App_Data folder. It is also not possible to specify the <Indentity /> element, as this is already specified in Machine.Config, and is not allowed to be specified in Web.Config.

I have tried moving Utils.LoadExtensions() from Application_Start to Session_Start and enabling session in the <pages /> element in Web.Config. This enables me to visit the page, but I still cannot save or edit anything (posts, users... ). Is there any solution for me?

Mar 16, 2011 at 9:38 AM

Although the error occurs in Utils.LoadExtensions(), the main error message at the top is:

"Access to the path 'D:\hshome\gertbrigsted\\App_Data\datastore\extensions\BBCode.xml' is denied."

And I'm prompted for username/password credentials before the error message appears, and then it appears.  This means that the blog is trying to write to that file, but doesn't have permissions to write to it.

That's good you have a full trust server, but that doesn't necessary mean that Write permissions are setup on the App_Data folder.  If your site is on a shared hosting plan, usually there is a control panel where you can control file permissions.  You would want to give full access to the App_Data folder for the ASPNET account (sometimes aka Network Service).

Other data also needs to be stored in App_Data, such as blog posts, comments, etc.  So getting file permissions setup on App_Data is imperative.

If you're not sure, you can ask the hosting provider about setting up file permissions.

Mar 16, 2011 at 10:18 AM

Thanks, but as I said, it is not possible for me to change the permissions on the App_Data folder. Can I somehow make BE write to the App_Data folder using the impersonated identity, or how does it work?

Mar 16, 2011 at 9:31 PM


Nov 9, 2011 at 3:54 PM

has anybody figured this one out?

I have also the same error as described in the first post.

I have hosting on surftown, and my site is set to ASP.NET 4.0 in Integrated Mode.

I just downloaded the web version of 2.5 and uploaded it to my site.

It asks me for credentials, if I cancel on that prompt where customerror is set to off, I get the same error as mentioned in the first post.

System.UnauthorizedAccessException: Access to the path 'D:\hshome\***\***\App_Data\datastore\extensions\' is denied.


Is there a way to resolve this without changing security in the App_Data folder, as I'm not allowed to do that?

Nov 9, 2011 at 5:56 PM

You can switch to DB provider, that does not write to the file system. But I'm guessing your host should have some way to set directory write access, may be you need to contact support or use some kind of control panel. Without it service would be almost useless.

Nov 10, 2011 at 12:33 PM

None01 - Also, check out the home page of  I see that they have posted info on the tweaks they made to get BlogEngine.Net to work on Surftown.  May be helpful.  Also, if that's not enough, maybe contact that blog owner for further tips since they found a way to make it work. 

Nov 10, 2011 at 9:20 PM

My provider will not change security rights.

But they are supporting impersination, I can't just see how to implement that into

rclabo: yeah I found that post too, but it doesn't seem to work in the newest version 2.5 :-(