BE 2 - Not Saving Comments nor Previewing

Mar 24, 2011 at 2:34 PM

Hello,

I have seen a few articles out there but all seem to be on BE prior to 2.  The Blog works, I can create posts, edit them and so on.  I got a message from someone that they could not add a comment, the animation just keeps spinning.  I tried it myself with the same results.  This is the case with Previewing the comment and trying to Post it.

In IE9 I openened the F12 tool and got the following message when I clicked on the save comment:

SCRIPT5007: Unable to get value of the property 'value': object is null or undefined
js.axd?path=Scripts%2fblog.js&minify=, line 1 character 2181

When I click on that 2nd line which is a link, it takes me to this:

h=BlogEngine.comments.websiteBox.value

Can anyone help me please?  I thought all was good to go when I started posting.  Apparently I was mistaken.  Hope it is an easy fix.

Thanks,
Kevin

Mar 24, 2011 at 2:57 PM

Okay, I figured out my own issue.

I guess I will file this as a bug as well.  I looked at the line that was causing the error:

var website = BlogEngine.comments.websiteBox.value

I noticed I had no website box in my comments section.  I have already had to fix a few issues with the BluePigment theme I have chosen to use so I figured it was there.  Turns out it was not.  The problem is in the blog.js file.

Basically, my setup did NOT have the check in the "Enable Website in comments"  And the UI was doing its job.  However, the javascript was not as smart.  There would be no websiteBox if it was not in the UI and thus would fail.  Needs to have some sort of IF wrapper around that line in the code to only check it IF the "Enable Website in comments" is checked.

Glad it is up and commenting!!

Thanks me.

Hope this helps someone else in the future.

Mar 24, 2011 at 5:47 PM

As far as I can tell this is a known bug that was introduced a few builds ago. As you have discovered, the work around is to activate the "Enable Website in comments" feature. Which build are you using?

Mar 24, 2011 at 5:49 PM

Kewl.  Working on: 2.0.0.46

Apr 17, 2011 at 7:40 PM

Under my Settings - Comment Settings - I see an "Enable Comments' button but not an 'Enable Website in Comments' option to check. 

Where can I find this?  Am i looking in the wrong place?

Apr 18, 2011 at 2:11 PM

It's under that Appearance section on that page you specified.  Right under the # of comments per page drop down list.

Apr 18, 2011 at 5:07 PM

The problem is that it is not there on my setting page!

Under Appearance I have:

Avatars

Comments per page

Show Country chooser checkbox

Show Live Preview Checkbox

Show pingbacks and trackbacks checkbox.

There is no Enable Website in Comments checkbox.

I just downloaded the latest version from the site. Are you looking at a developer version at something that is not deployed?

Thanks.

Apr 18, 2011 at 5:49 PM

No.  I had downloaded the lastest in mid March 2011.  I am running version 2.0.0.46.

Apr 26, 2011 at 7:28 AM

The same here.

And then mayby not, because if i use the standard theme comments works, but not on any other themes, and anyway, there i not a "Enable Website in Comments checkbox." in admin.

Solution, yes please.

Apr 26, 2011 at 1:21 PM

I had an issue initially of not being able to see comment and it was a problem with the Theme.  There are a fair amount of themes out there and although they may look good, whoumever wrote them did things a certain way and only implemented what they wanted/needed.  This of cousre would not include all features.  If I were to write one, I would implement everything but that's just me.

Apr 26, 2011 at 7:22 PM

I have made my own theme, based upon the standard theme. Copy, paste the code, and then playing around with css.

The same theme runs well in the 1.6 version. but not in version 2.0.0.46 In this version only the standard-theme works.

And again, i do not have the. "Enable Website in Comments checkbox."

Coordinator
Apr 26, 2011 at 7:49 PM
stass wrote:

... And again, i do not have the. "Enable Website in Comments checkbox."


If you don't have "enable website..." checkbox in 2.0.0.46 that is the problem, it should be there. Under settings/comments. If not, you might need to re-install, may be downloaded files got messed up.

Apr 26, 2011 at 8:34 PM
rtur wrote:
stass wrote:

... And again, i do not have the. "Enable Website in Comments checkbox."


If you don't have "enable website..." checkbox in 2.0.0.46 that is the problem, it should be there. Under settings/comments. If not, you might need to re-install, may be downloaded files got messed up.


Could you mayby tell me the name of the file i should look for, to see if it´s there.

I have re-installd 3 times now since feb. Last time yesterday, in a new and clean subdir.

Same result.

Coordinator
Apr 26, 2011 at 10:27 PM

Sure, take a look at /admin/Settings/Comments.aspx

For 2.0.0.46 it should look like this - note that "cbEnableWebsiteInComments".


Apr 27, 2011 at 7:02 AM
rtur wrote:

Sure, take a look at /admin/Settings/Comments.aspx

For 2.0.0.46 it should look like this - note that "cbEnableWebsiteInComments".




It´s not there. I have made 2 new downloads on 2 diffrent pc. Same results.

So. could you mayby try, and see if it´s there when you download. (Web)

Coordinator
Apr 27, 2011 at 3:13 PM

You probably downloading 2.0.0.36 from the "downlaods" tab and not 2.0.0.46 which only available from "source code" tab. When you go to admin panel - what version number diplayed in the footer?

May 10, 2011 at 9:06 PM

I downloaded the most recent versions of both to a virtual machine of mine from CodePlex. Both are running 2.0.0.36. I know it's a stupid question but don't you think it would make sense to put 2.0.0.46 up there so people could actual get a working copy????? Or give a different FTP address where the 2.0.0.46 could be downloaded.

I am not trying to be nasty. I'm just frustrated.

May 13, 2011 at 11:16 PM
rtur wrote:

You probably downloading 2.0.0.36 from the "downlaods" tab and not 2.0.0.46 which only available from "source code" tab. When you go to admin panel - what version number diplayed in the footer?

2.0.0.46 does not seem to be on CodePlex. Is there somewhere else I can download it?

May 16, 2011 at 9:00 PM

Ok, did that, but still no luck, just a lot of errors. And im not into programing, to old, to little time, so until it fixed i go for Discus.

May 16, 2011 at 9:03 PM

RossTerman wrote:

I know it's a stupid question but don't you think it would make sense to put 2.0.0.46 up there so people could actual get a working copy????? Or give a different FTP address where the 2.0.0.46 could be downloaded.

I am not trying to be nasty. I'm just frustrated.

I wonder to, just as frustrated