Installing BE 2.0 on IIS 7.5

Apr 7, 2011 at 11:33 AM
Edited Oct 24, 2011 at 9:40 PM

I need step by step instructions on how to install BE 2.0 on IIS 7.5

It runs BE 1.6 ok but not BE 2.0

Getting this error:

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

Server Headers response info:

Content-Type: text/html
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET
Date: Wed, 06 Apr 2011 16:01:58 GMT
Content-Length: 1208

------------------------------------------------------------------------------------------------------------------------------

 

Does this applies to IIS 7.5 ?

 

HTTP Error 500.0 - Internal Server Error Integrated .NET mode

You may get an error as above, which suggests that you should run: %systemroot%\system32\inetsrv\APPCMD.EXE migrate config "site_name/BlogEngine" For once the instructions are correct... just open an admin command window, paste the command from your error message in there and run it.

web.config

If you have tried everything else and simply can't get the handlers to populate for your App_Data folder, it may be worth looking for a little file called "web.config" in the root of your site. Deleting this and then reinstalling the blog software fixed that problem for me.

application pools

No really, these applications have pools. Must be rich or something. Anyway, if you run with the default IIS7 settings, they'll get nice new shiny pools which don't work with this software. When you convert the BlogEngine folder into an "application" (what is one of those anyway?), don't just leave the "Application pool" setting as the default.Click the "Select" button and the choose "Classic .NET AppPool" from the dropdown. If you don't do this, some of the software will fail in strange ways. Trust me on this, at least it's true for 1.0 and 1.1.


Java Blog

Coordinator
Apr 7, 2011 at 12:10 PM

Getting the error message I think is key.

If you haven't already, I would switch the <customErrors> mode to "Off" in the web.config file.  If you don't get an error message at this point, you could try replacing Application_Error in global.asax with the one I posted in this thread on Nov 9th.

Some people have better luck when using the non-integrated (classic) application pool mode -- although integrated mode is preferable overall.