Theme won't "Stick"

Apr 7, 2011 at 10:23 PM

I've gotten my new version of the BlogEngine running, and am trying to customize it. I've downloaded a new theme and extracted it to the correct folder and selected it from the "Settings" page of my dashboard. However, every time I save it - nothing happens. I see it in the drop down list, I select it, I save the page. I go back and it is no longer selected and it has not loaded any of the new theme. I'm using the newest version of the BlogEngine (just downloaded it) and my OS is Windows 7 and I'm developing in .Net 4.0 using VS 2010. Any suggestions? TIA,

Coleen

Apr 8, 2011 at 9:33 AM

Delete all the other themes Haha

Apr 8, 2011 at 12:15 PM

Can you save any posts or pages or change any other blog settings like the title? I'm wondering if your permissions on the App_Data folder are correct and preventing anything from being saved.

Apr 8, 2011 at 1:35 PM

LOL cyclopedia - that's sort-of what I ended up doing! I copied everything from the theme that I downloaded into the "Standard" theme after deleting all the files in the standard theme...it works now - but it is going to be a problem if I can't save anything...

MGD, Yes I can add a new page, update it, etc. but maybe I didn't get the App_Data setting correct? I've gone into IIS and set the preferences, I've clicked directly on the App_Data folder and set them, I've done it every way I can think of, so I "think" that they are set correctly, but It is just extremely odd that it won't save the darn page!  Maybe you can tell me what the proper way to set the write permissions is, and I can go and double-check that I do have them set correctly? 

Thank you!

Coleen

Apr 8, 2011 at 3:17 PM

I just went and double-checked my settings in IIS and on the Folder properties. All Users are set to have write permissions, and I still can't save the Settings page. The odd thing is that is "Shows" that the page is saved, but nothing changes. This is VERY frustrating. Then I have to go track it down in all the XML files and change it there. This is "Supposed" to be changed by just going into the Settings tab on the dashboard - right? Please help - what am I doing wrong? Did I download the wrong version? I don't really want the Source Code version, I am not at a point where I can write my own source code for this. I downloaded the newest BlogEngine.NET 2.0 (web) files, so this should work..right? ny help would be greatly appreciated.

Coleen

Apr 9, 2011 at 1:18 AM

Are you trying to do all of the page saving and editing from within VS2010 or are you running on the local machine's IIS (http://localhost)?

Apr 9, 2011 at 12:45 PM

I'm editing from VS2010. I prefer that way over working through IIS. I could use IIS, but since I have several projects I'm working on and not all of them are BlogEngine projects, it's easier to use VS. Truthfully, yesterday after spending about 4 hours on this I gave up. I have a good working "Testblog" that I used when I created CorozalToday.com (which was up and running for several months but the owner just moved and is no longer maintaining the site so it's down now.) So I copied the directory (permissions and everything) and it works perfectly. Now I'm using the previous version of the BlogEngine: 1.3.0.0 instead of the newest BlogEngine.NET 2.0 (web). I don't understand why I could not get it to save. All the settings (as far as I can see) are the same. I am definitely missing something if no one else is having this problem. Believe me, I have gone into the IIS Manager, set the folder for the new BlogEngine to run as an App, checked, double-checked and triple-checked that the write permissions are set, double-checked that the folder permissions in VS are set to allow write privileges, and it still won't save! Obviously, I have missed something and I have no idea what. Thanks for any help you can provide.

Coleen

Apr 9, 2011 at 3:01 PM

Well I went back and followed all the steps in the "Installation Screen-cast" here: http://www.nyveldt.com/blog/post/BlogEngineNET-13-Installation-Screencast.aspx and followed the steps - as exact as I could since I am using IIS 7 and Windows 7 and the new BlogEngine 2.0. There are definitely some differences on how it needs to be set up, but if you search through the IIS foldr icons, you can find the icon for Application Settings, click on that and set it to run as an app, then in the permissions when you right-click and go to set the users group - if you try to set it as ASP.NET User - nothing is found. I double-checked my original set-up and yes, I HAD set the write properties for ALL Users groups. I don't know why the original installation failed, but this time, when I went into the Security for the folder, instead of trying to add ASP.NET I selected the IIS_IUSRS and gave that full control, and now it works. I know that I had previously given write permissions to that group - I checked it three times!

The little green menu at the top came up to show it saved this time, when I saved it after adding the new theme, and the new theme has been applied. I honestly don't know exactly what I did differently this time, because I had done all of those steps on the previous installation, but not in that order.  If I had a way of creating a little demo video so that others trying to install the new version on IIS7 and Windows 7 can follow easily I would because I know that the steps to get the BlogEngine are just enough different with the newer versions of everything that it makes it a little difficult for complete novices to follow along if they don't undertand what/where they need to go in IIS7 vs. in IIS 5 or 6, or when using a different version of the Windows OS.

It does work now, so if anyone else runs across this problem, try re-installing the entire BlogEngine and follow each step carefully. If you get lost in the process please come here and post. Hopefully, someone who has the right software can make an updated video of the installation process. Thanks for everyone's help.

Coleen

Apr 9, 2011 at 3:06 PM

That was my next question, did you have permissions set up for the IIS_IUSRS account on the app_data folder. Glad you got it figured out!

Apr 9, 2011 at 3:40 PM

Thanks MGD, I'm glad it worked too. I like to try to stay up-to-date with the newest versions of stuff ;-)

I do know that I had set the IIS_IUSRS account to full permissions - I checked that several times. It's just weird. Maybe the order in which I did the steps - maybe I missed something else (like making sure it was set to run as an app - but the icon for the folder changed to show it as an app in IIS...) maybe it was just a glitch - but I am glad it works now. Thanks!

Nov 24, 2011 at 1:33 AM
Edited Nov 24, 2011 at 1:35 AM

Hi,

I am having the same problem regarding saving settings in BlogEngine.Net 2.5.  

 

I can login, post and add users but whenever I try to save settings on any of the Settings pages (off the Settings tab) nothing is ever saved. I am clueless as to what the solution maybe - DiscountASP support say that the App_Data folder has Write permission set.

http://itradepod.com/pmaBlog3/admin/Settings/Main.aspx

(the default passwords are still in place for you to try)

 

Any help or suggestions would be much appreciated!

Coordinator
Nov 24, 2011 at 3:42 AM
Edited Nov 24, 2011 at 3:45 AM

Seems like you somehow ended up with 3 jQuery scripts on your site and they conflict with each other. You have "jquery.js", "jquery-1.4.1.js" and "jquery-1.4.1.min.js", probably all in your scripts folder. Try to remove both 1.4.1, you don't need them, just leave "jquery.js". Could also be one of the extensions installed jQuery, but I don't see any custom extensions on your site.

Nov 24, 2011 at 7:19 PM

Hi rtur,

 

I tried removing those files and only left those that were actually being used but I get the same save settings error.  Again the link is:

 

http://itradepod.com/pmaBlog6/admin/Settings/Main.aspx

 

and the passwords are default

 

 

Coordinator
Nov 25, 2011 at 12:20 AM

You still have same 3 jQueries loaded from the "~/scripts" folder. Example: http://itradepod.com/pmaBlog3/Scripts/jquery-1.4.1.js - still there.

Nov 25, 2011 at 12:53 AM
Edited Nov 25, 2011 at 1:03 AM

Hi rtur,

Thank you for your message.
The link where I removed the excessive jQuery script files is now at http://itradepod.com/pmaBlog6/admin/Settings/Main.aspx instead of the old link http://itradepod.com/pmaBlog3/admin/Settings/Main.aspx as I mentioned in the previous post.
I had to create a new folder ( /pmaBlog6) and a fresh BlogEngine.Net installation with the jQuery files removed because for some reason I received an error message when I tried to delete the files from the other BlogEngine.Net installation (/pmaBlog3), preventing me form deleting the files.


Thanks so much for taking the time to help me with this and hopefully we can eventually find a solution to this problem.

On Fri, Nov 25, 2011 at 12:20 AM, rtur <notifications@codeplex.com> wrote:

From: rtur

You still have same 3 jQueries loaded from the "~/scripts" folder. Example: http://itradepod.com/pmaBlog3/Scripts/jquery-1.4.1.js - still there.

Coordinator
Nov 25, 2011 at 1:23 AM

You need to remove redundant jQuery files from "scripts" folder, not a link. All scripts from "~/scripts" loaded automatically by application, this is a special folder for JS that are global in scope. Do you have any modifications on your site? Any extensions/widgets/themes that could bring that extra java scripts?

Nov 25, 2011 at 2:15 AM
Edited Nov 25, 2011 at 2:16 AM

Hi

Thanks for your message. Please, if you click on the following link:

 

http://itradepod.com/pmaBlog6/Scripts/jquery-1.4.1.js

You will see that those extra jQuery files are no longer in the Scripts folder.  

I do not have any modifications or any extensions/widgets/themes that could bring the extra java scripts.

Coordinator
Nov 25, 2011 at 3:20 AM

For pmaBlog6 it looks like "jquery.validate.min.js" is missing - you do need this one.

If you don't have any modifications, it could be safer to wipe up clean and re-upload files. Sometimes FTP client makes mistake, files get locked or corrupted. It could be that your upload files got messed up and clean start would be better. 2.5.0.6 should work out of the box with no issues, those extra JS files in "scripts" should never be there in the first place, they not part of the install package.

Nov 26, 2011 at 2:01 AM

Thank you rtur,

As soon as I read your comment that "those extra JS files in "scripts" should never be there in the first place" I immediately examined the entire contents of the Scripts folder in my Visual Studio 2010 MVC 3 Web Application project and compared it with the original Scripts folder that I download from the BlogEngine.Net website.  This comparison confirmed that you were right so I simply replaced the Scripts folder in my Visual Studio project with the original folder that I had downloaded.

 I cannot thank you enough for pointing me in the right direction with this problem.  I am not sure how those extra JQuery files got there. The only thing I can think of is that the extra jQuery files were some how generated during the 'Convert to Web Application' process that I did in Visual Studio 2010.  Is there any software out there that I can use to batch compare all the folders against the original downloaded folders so that I can check if any files have been added or taken away from other folders may have been affected?

Now I have BlogEngine 2.5 as a Web Application fully working within a subfolder of my existing ASP.NET 4 MVC 3 Web Application, thanks to your help.   Now I just need to learn about themes and learn if it's possible to integrate the blog into my existing MVC 3 Web Application's layout so that I don't have to use an iFrame. The iFrame Layout version is here http://www.itradepod.com/home/blog

Thanks again.

Coordinator
Nov 26, 2011 at 4:29 AM

Cool, glad it worked for you. I usually use DiffMerge to compare 2 folders (or files), it is free and works great for me.

Dec 4, 2011 at 10:03 PM

Now I'm really struggling to get BlogEngine.Net 2.5 working with my existing ASP.Net 4 Membership tables.  I've done everything in the ReadMe file.  But I still get an error about the xmlMembershipProvider object not being referenced. Is there a discussion thread regarding membership that deals with this? Thanks in advance.