Extremely slow load times

Apr 16, 2011 at 1:04 AM

I've been successfully running on IIS7 with a .NET 4.0 Integrated app pool with no issues. Something recently changed that has caused my blog to run extremely slow, regardless of how many times I hit the site.

Any ideas why this might be?

Coordinator
Apr 16, 2011 at 8:50 AM

I would try turning off "Compress WebResource.axd" in the control panel settings.  And any other compression options you see there.

If it's still slow, I would then try temporarily disabling Extensions and removing Widgets.

It's probably not related, you could also try temporarily changing themes to see if your theme specifically is causing any issues ... although unlikely.

Apr 17, 2011 at 12:43 AM

Yup, turns out the "Twitter" widget was the culprit. I removed that and everything was back to normal. Now to figure out what is wrong with that widget, but at least the blog is back up and running. Thanks Ben!

Apr 19, 2011 at 3:41 PM

Hello..  had the same problem and because we activated the HTTP Compression.

Thanks Ben!

Sep 16, 2011 at 7:50 PM

I had same problem. And found it was because the Twitter widget setting the twitter RSS url wrong.