BE deploy problem

May 6, 2011 at 8:53 AM

hi, I am a BE fan from china.

Everything worked fine on my test server(windows7 Chinese edition) until I put them on the godaddy share hosting server, all image files (like this "<%=Utils.AbsoluteWebRoot %>pics/image2.jpg") in master page were down , even the blogroll rss icon, It seems like all image requests are proccessed by the "image.axd".I moved these images to upload path and changed the path like upload images for temporary solution

and another thing, when I login, all pages are full of unrecognizable characters, nothing readable, like this:

��`I�%&/m�{J�J��t��`$ؐ@�������iG#)�*��eVe]f@�흼��{����{����;�N'���?\fdl��J�ɞ!���?~|?"��Ey�')=��y6�����h����z��<=���~|W>�Z5�u�A:�f��/>����y�(��G�d^ϲe��!z���Ѳ�Y)5��G��A�8�VeU?������/I=����Yd�E��n�գt����/�q� �IU�n �ۻ�/No�������N�|� ��&�} �0��euU���?_O�Y��T˦*s�3�0_�/� �ۼV�@ʄJ��TH�����Y>���-���tY-���e^7�U���ŋ:�[�`��+�'U�V�G����]�ݻU��e��F�v{^/gy]�{�#����.���u��su�S��]���Uq�?��' 賏��E�d�� B����w�^�5�[�*-���ww��Ż���ժ,������N��Y;�lwg�wO1�� ��5EI��%`�n�{G���+���ޣw��[ 

Any suggestion would be appreciated?

and if any help for this: I download the source files from codeplex, changed a little bit with vs2010, that means there is a upgrade operation.

May 7, 2011 at 4:56 AM
Edited Oct 24, 2011 at 8:36 PM

Try looking at these posts:


Hopefully these can help they helped me.


Also try a clean install again.  Delete everything then reinstall fresh again.


Some times that helps.



Sometimes just reloading the web.config  file does the trick.  Delete it on server then re upload it.

Java Blog

May 7, 2011 at 2:09 PM

I use WinHost and have been fighting this problem for a few days, trying different things to include the above, with no success - works 100% on my local dev box (Visual Studio 2010 and IIS 7.0).

I've been using BlogEngine for my on a different ISP but they aren't keeping up with the times and I needed an ASP.NET MVC3 host - I'll be keeping the server until I figure this out...

Note: Like you everything looks good until I log in, once logged in the following is all I see until I close the browser.

��`I�%&/m�{J�J��t��`$ؐ@�������iG#)�*��eVe]f@�흼��{����{����;�N'���?\fdl��J�ɞ!���?~|?"��Ey�')=��y6�����h����U^gmQ-�i�.g�,o�lR������i�^��"?�+�=M{|�N��u��ϫe�}�-����G?�׳l�}tȟ^��ż}���EV�G u�(?��Ӫ��G�2��=�%�w�@} ���(��m�z�n�_��%>���9��٭!~{7����0{��=X��I�������oA�M�uU���?_O�Y��T˦*s�3�0_�/� �ۼV�@ʄJ��TH�����Y>�����j��.����b}��ή�y]Wԗ�}R�m�x�����uڽ[e�Y6)idi���r��eA��>�>�����~_��1'
P�>���Y��]�$���~r��>��j^��G�[ �!�{��u^Ӹ�SY�L?����.>N�W���2����:�*f���ݝ��=�L|�+�~�%���.���2�;J�!��ƳG��@,=Ϧ�g�EV��o��K�����e~I?_����e��*�X�Y=J���uq�FH19J��ʹ.V���N����z —$��i�ߥՔ�R1[��������ӵ|{�pB�*��u���4�q��̳�F�_�7#LߦmM�!>��EErP,�!< .�T�V���!lҫy�VmZ��`�.4i�m5��������c�>��z��YQ62���M�/ƯiTu�^�tSN��>!IՒ ���&?]�[�[V��Y��G��v����'��(=ya�<ڻ��hT�J�˺�,����Ʉ<�$;⤊����:��ؗ9V��|2� ܲ�;�'�z`Z"�����y�T�V�O�=8؄�E�����������/��O�� �l��o)���=8_.�W�l���T�q}Ѥ�{�t�;���Ơ\]�c@~�Yi���x��>�w�?�Q��h�2���Ą��W��|�˭'��ْ�uZ�g9��E�<�a%�����eU,I��͎�ۼv��ス��^?Gf�f�7��R��3�ık�E1���:o����7��:[�WU�6����w��v��>�����x3/Mb�h.��Lz���ɗMђ� �_�|��)cf�K����b��[[�ͼ�J��T�ɐ-h���麁����t�P��Ź�ی�_��tI�1g�aNoxa)�)�6��U�����ey�Mi\������>��Q�,Zی�����
May 7, 2011 at 2:42 PM

We have to remove the "rights" attribute from the Web.Sitemap - seems to be a .NET 4.0 thing.  Found answer in the following: 

Once I removed the attributes the site loads without issue.  

May 7, 2011 at 3:09 PM

Note:  I added the Automotive theme and the site returned to showing gibberish (be careful what themes you load).  To recover easily I deleted the Automotive folder, renamed Standard to Automotive, and ftp'd a new Standard folder.   Site is back online now.

May 8, 2011 at 1:49 AM

thank u billrate, problem solved after remove all words include "right" in web.sitemap.

May 11, 2011 at 6:32 AM

But the image problem is still there ,anybody got a suggestion?