This project is read-only.

Blog just throws 404 errors

May 28, 2011 at 8:55 AM


I am running as a child application inside a ASP.NET 4.0  site on IIS 7 Integrated mode. Since I Upgraded the root application, the blog does not work anymore. Browsing the blog's root url results in a 404 error.

I tried using an older backup of the blog instead of the current version, but that did not change the problem.

I even tried installing a fresh copy of in that directory and I still the same a 404 error.

Installing the blog in a different directory as a regular web application (not child application) works as expected.

Please help! I am almost desperate enough to resort to using a proxy server! :-)





May 28, 2011 at 10:11 PM

It's not going to be easy for anyone here to find a solution for this since we don't have the parent application installed (or available) to test with or understand what types of conflicts might exist.

You might want to try wrapping the <system.web> and <system.webServer> sections in the parent application's web.config files with location tags that use the "inheritInChildApplications" attribute.  You can see an example of that in the March 2nd post by me in this thread.  This would be a change you would make to the PARENT application's web.config file.  It would make it so any settings in that parent application are not propagated down to the child application (BlogEngine).  It may or may not solve the problem, but is probably worth trying.

May 29, 2011 at 12:31 AM


Thanks for your reply. I realize this is not easy  to trace, I was just hoping this is one of the more common errors.

I've tried the inheritInChildApplications attribute (in fact I had already tried it before), but it did not have any effect. The problem still persists just as before.

May 31, 2011 at 11:27 AM

I don't think it has anything to do with BE itself. This seems more like an issue with how your application is configured in IIS. Few things to check:

1. In correct application pool

2. Application pool does not have correct identity which translates to access denied errors on

If you want to send me some details about your configuration, I will be more than happy to assist you.