Upgrade errors when deploying version 2.0

Topics: ASP.NET 2.0, Themes
Jun 27, 2011 at 2:35 AM

Hi there,

I just upgraded my blog from 1.5 to 2.0 and just thought I'd pass along some issues I ran into;

1) My stardust theme was toast in the new 2.0 engine, I had modified it a bit, but nothing crazy so this was a little weird, not a big deal since I switched it over to Boldy.

2) The biggest issue I ran into was the having to remove the following configuration line from my web.config.  This was causing my site to blow up on my ISPs page.

<httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384"/>

What is this trying to do?

Thanks - Greg.

Coordinator
Jun 27, 2011 at 8:57 AM

All of those attributes in <httpRuntime> are documented here.

I don't recall <httpRuntime> causing any problems with BE applications, but I don't think any of those values are necessary for BE to run, so should be safe to remove <httpRuntime> all together.