Is .net 3.5 support being dropped going forward?

Jun 29, 2011 at 10:34 AM

I notice that the newest version (2.5) only works with .net 4.  Does this mean that the door is now closed on .net 3.5 compatible versions and anyone wanting the latest version/features/fixes going forward will have to move to .net 4?

I'm wondering if there are plans for future new versions that will offer compatibility alternatives with either .net 4 or .net 3.5, like some other open source products do at the moment?


Jun 29, 2011 at 7:20 PM

Current release is not compatible with 3.5, you do need .net 4.0 running on your server.

There no plans to fork 3.5 compatible version, because lots of new features not available in 3.5 framework, Razor been one of them but there are many others that used or we plan on using that do not exist in 3.5.