This project is read-only.

cannot run recaptcha

Jul 28, 2011 at 12:31 AM
Edited Jul 28, 2011 at 12:49 AM

recaptcha is enabled but it doesn't show up in the comments page. the view page says

Source for [C:\inetpub\wwwroot\new-blog2\App_Code\Extensions\Recaptcha.cs] not found

actually the path is ...\Extensions\Recaptcha\Recaptcha.cs ...
copying all the content of this folder in the one higher gives me a compilation error ... any help?

thank you


Jul 28, 2011 at 12:49 AM

Did you check "show to authenticated users"? Any JavaScript errors on the page? Have you setup "key" in the extension properties?

That source not found message is fine, not all extensions expose source code.

Jul 28, 2011 at 1:03 AM

hello rtur

thank you, I double checked it, I use recaptcha on the same machine in a 2.0 blogengine blog and it works. it's got the same settings

show authenticated users is disabled, but I checked being loged out, the keys are set and there is no java error ...

Jul 28, 2011 at 1:51 AM

okay I set it up all new ... on an natve install recaptcha works ... then i install the darkblog theme, which ist required, and the recaptcha dissapeares.

all the other blogs 2.0 have the same theme installed and recaptcha works