BlogEngine 2.5 renders only HTML page on Arvixe

Topics: Themes
Jul 28, 2011 at 6:26 AM

HI! I am relatively new to web hosting and such. I have installed BlogEngine 2.5 on my new hosting account with Arvixe. As far as I can tell, I have done everything correctly. The default BlogEngine site loads when I navigate to the site in my browser. However, no themeing whatsoever as applied - the page looks like a boring HTML-only page from 1992. I have tried several themes, and nothing changes. The Admin portions of the site work and render properly, just like they would on my local machine. But the client-facing pages do not. While I am semi-well-versed in programming, the web stuff is new to me. Any help would be greatly appreciated . . . ! Thanks!

Coordinator
Jul 28, 2011 at 2:52 PM

Try to go to admin/settings/advanced and clear check boxes for "enable http compression" and "trim stylesheets", see if it will help.

Jul 28, 2011 at 3:18 PM

Hmmmm. It's not letting me change ANY settings. I have write permissions enabled on the app_data folder. When I log in as "admin" per the default instructions, I can see all the settings, and as I said, the admin and settings pages render properly. However, when I go to the "users" page, there are no users or roles visible (not even Admin, althought he page thinks I am logged in a admin . . .). When I click on "create user" or "create role" nothing happens. When I go to change the checkboxes you indicate above and then save, the form allows me to uncheck, and then save. However, a page refresh restores things back to the old settings. This smells like some sort of permissions iussue, but I have enable read/write permissions all the way out to the top level of my site and all child objects, with no change. This is where I begin to feel inept . . . I there some reason that the site is unable to access the code required to run properly? Or am I missing something stupid with my permissions settings (working on a remote host is real new to me . . .).

Coordinator
Jul 28, 2011 at 5:44 PM

In the Arvixe control panel, navigate to website and virtual directory where you running BlogEngine. Make sure "enable write permissions" checked and under "extensions" tab selected asp.net 4.0 integrated mode. It should be default, but who knows...

Jul 28, 2011 at 11:49 PM
Edited Oct 24, 2011 at 8:07 PM

Simple solution had this problem yesterday :)

 

Your web.config file some how got mess up.   I notice this alot with asp 4.0  just reupload your web.config from your local machine. 

 

The one on your local machine should be 17KB  the one on your server should be 14KB.

 

Just replace the 14kb web.config with your local  17kb web.config

 

Now you will have Css back.

After you replaced the web.config

 

You might have to restart the app pool.

 

Have two ways:

 

1. Turn off and on one of your extenstions

2. Re Upload a .dll file   like  blogengine.core.dll or  the ajax.dll  <--- smaller quicker.

 

Doing this restarts the app pool and now close your tab or window where the site is at.

 

Open it up fresh hit refresh a couple times if not working.

 

Should have css back in about 1-10 mins or so.

 

 

The Mystery still remains through why does this occur?

 

If anyone knows please let me know :)

 

Hope this works for you if not let me know :)

 

Brian Davis

Java Blog

Jul 29, 2011 at 2:59 AM

Nice! You were correct. The webconfig file on the Arvixe install is missing a section of code. This code can be inserted at approximately line 169, just after the <staticContent> and <modules> sections.

Works great now! Thanks!

<handlers accessPolicy="Read, Write, Script, Execute">
<add name="FileHandler" verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="ImageHandler" verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Syndication" verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Sitemap" verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Trackback" verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Pingback" verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="OpenSearch" verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="MetaWeblog" verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="RSD" verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="CssHandler" verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Javascript" path="js.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Resource" verb="*" path="res.axd" type="BlogEngine.Core.Web.HttpHandlers.ResourceHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Rating" verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Opml" verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="BlogML" verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="SIOC" verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Apml" verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Foaf" verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
<add name="Html" path="*.htm" verb="*" type="System.Web.StaticFileHandler" resourceType="Unspecified" preCondition="integratedMode"/>
</handlers>

<directoryBrowse enabled="true" />
<defaultDocument>
<files>
<clear />
<add value="default.aspx" />
<add value="Default.htm" />
<add value="Default.asp" />
<add value="index.htm" />
<add value="index.html" />
<add value="iisstart.htm" />
</files>
</defaultDocument>

 

 

 

 

 

 

 

 

 

 

 

Jul 29, 2011 at 3:00 AM

@rtur - I am now to Codeplex, so the problem fix above is probably less than elegant. Not sure why the Arvixe install is missing that code (at least on my install), but that fixed things right up . . .

 

 

 

 

 

Jul 29, 2011 at 4:23 AM

Its not specific to any server or web hosting company.

 

It seems to be related to asp.net 4.0   if you first install  asp.net 2.0 never had this problem.

 

Just when using asp.net 4.0 for some reason  4.0 changes the web.config file sometimes. 

This has happen to me about 5 times why it occurs is still a mystery to me!!

 

But all you do is just re ftp your web.config and that should do it :)

 

Glad it worked for you!!

 

xivSolutions --  I am here to help you anytime you need help with BE.

 

You can also email me at kbdavis07@yahoo.com with any questions and you can also add me to

 

Microsoft Live Messenger if you like :)

 

My way of Paying it Forward for BlogEngine.Net development  team they done such a great job!!!

 

http://www.kbdavis07.bloggersonline.com/

 

Have a great day!!

 

Brian Davis