Cannot post comment?

Topics: Controls
Aug 11, 2011 at 10:25 PM

I try to enter a comment to a Post but when clicking Save comment nothing happens. No posting is being done. No error in webbrowser. No error in event viewer. Nothing happens.

 

Any ideas?

Aug 13, 2011 at 1:53 AM
Edited Oct 24, 2011 at 8:14 PM

Can you give the URL to the site so I can try it my self?

Java Blog

Aug 13, 2011 at 9:20 AM

http://neteject.com/

 

Thanks

Aug 13, 2011 at 8:30 PM

Its the theme!!!!!!

 

I just switch my theme to the boldly theme too

 

same problem as yours .

 

Looking at the

Standard theme vs Yours

I notice the only difference is this:

 BlogEngine.comments.checkName = true;

vs

BlogEngine.comments.checkName = false;

 

Other than that I don't see any other differences.

Some how need to change

BlogEngine.comments.checkName = true;

That might solve the problem.

But its a theme issue.

Not BE

Switch your theme and your comments will work. 

Aug 13, 2011 at 9:17 PM

Thanks, but which file is it? Sorry, I tried to search but did not find those lines anywhere?

Aug 13, 2011 at 9:52 PM

When looking at debug I see this line:

Error: BlogEngine.comments.nameBox is null
Source File: http://neteject.com/js.axd?path=%2fScripts%2fblog.js&minify=
Line: 1

But I see nowhere where this minify come from in the code.

Aug 14, 2011 at 1:27 AM
Edited Aug 14, 2011 at 1:37 AM

I have been looking and looking.

 

Should be some where in the theme folder.

 

Either the site.master or commentview or postview

 

but could not find it.

 

Rtur need your help here:) 

 

Its your theme any way :)

 

I bet it something to do with the converstion from

 

BE 2.0 to BE 2.5

 

Just what I don't know?

 

I have tried everything I could think of.

 

I am stump here.

 

 

I know its one of the files in the theme folder because if you switch themes

it works fine.

 

So its something that is inside of the theme folder.

 

Other wise would have the same problem when switching to other themes but do not.

 

SO it have to be 100% something is wrong in the theme folder.

 

Its for sure NOT a BE issue its a Theme Folder issue.

 

Getting same error:

 

setupMenu is not defined

BlogEngine.comments.nameBox is null
I put the tracking script in
the tracking place in admin:  <script type="text/javascript" defer="defer" src="js.axd?path=/blog/themes/Boldy/js/ddsmoothmenu.js"></script>
also deleted the .js min  since its already in the main /scripts folder.
Same problem.
????
Aug 14, 2011 at 8:33 AM

Thanks for your help - I have contacted Rtur about the issue.

best regards,

 

Henrik

Aug 14, 2011 at 5:53 PM

Let me and others know if you find a solution :)

 

Thanks,

 

Brian Davis

Aug 14, 2011 at 8:36 PM

I will, thanks!

Aug 21, 2011 at 12:47 AM

I'm experiencing the same behavior, but it's only all of my non-primary blogs that are affected.
I can comment on my primary blog, but not on any others.
All of the blogs are using the same theme.

Sep 14, 2011 at 6:07 AM

I'm experiencing the same behavior, but only in production (1and1.com is my Host Provider). But it works on my local machine. I'm using the standard theme.

Sep 14, 2011 at 10:53 PM

+1 on comments not saving with boldy ... freshly DL'd BE & Boldy on 9/14/2011 ...

Coordinator
Sep 15, 2011 at 3:31 AM
Edited Sep 15, 2011 at 3:41 AM

It is in the package details page and "readme" file, but I do have to make it work without manual step some day:

 

Add script reference to the admin/settings/custom code/tracking script:

    <script type="text/javascript" defer="defer" src="/blog/js.axd?path=/blog/themes/Boldy/js/ddsmoothmenu.js"></script>

    *** remove "/blog" if your site is in the root or replace with your site name if it is not "blog" but something else

 

If that doesn't work, you might need to check for JavaScript errors, sometimes it is 2 jQuery declared, sometimes Recaptcha can cause errors - try to uninstall/disable extensions to find the one causing JS errors.

Sep 16, 2011 at 2:18 AM

thank you ... fixed :)

<script type="text/javascript" defer="defer" src="/js.axd?path=/themes/js/ddsmoothmenu.js"></script>

Sep 19, 2011 at 11:56 PM

I'm totaly lost here

Add script reference to the admin/settings/custom code/tracking script:

    <script type="text/javascript" defer="defer" src="/blog/js.axd?path=/blog/themes/Boldy/js/ddsmoothmenu.js"></script>

 

Which file to put this <script type="text/javascript" defer="defer" src="/blog/js.axd?path=/blog/themes/Boldy/js/ddsmoothmenu.js"></script> in

 

TIA

Coordinator
Sep 20, 2011 at 2:27 AM
bjol wrote:

I'm totaly lost here

Which file to put this <script type="text/javascript" defer="defer" src="/blog/js.axd?path=/blog/themes/Boldy/js/ddsmoothmenu.js"></script> in

 

TIA

Not in the file, log into your website and go to Admin/Settings/Custom Code in your admin UI. There are two textboxes, one for custom scripts that will be appended to header section of the page and one that will be appended just before "</body>" tag. Paste this script into second textbox.

Sep 30, 2011 at 7:48 PM

As an FYI, I've encountered this at Sueetie.com and found that turning off WebResource.axd Compression did the trick.  I posted on it here.

Thanks,
Dave 

Oct 24, 2011 at 6:15 PM

Hey all,

 

    I too am having this problem and it is driving me around the bend. No of the tips above have helped in getting comments to work on my machine or when i push to a server. The only error i keep on getting is "BlogEngine.comments.nameBox is null" which isn't helping me. there is a lot of javascript going on but i can't seem to trace down the problem.  Is it just me that is hitting a brick wall or has there been a lot of people having this problem? Is there a simple fix for this? Firebug as i said is only reporting the following error "BlogEngine.comments.nameBox is null" all scripts are being loaded correctly. i have taken out some of the extensions and still no go.

 

Any help on this would be much appreciated ...

Oct 24, 2011 at 6:41 PM

 

For me i though i was after putting the script into the custom code section correctly as i was not getting an error from firebug about missing script. The problem persisted for few days and i let it be over the weekend. fresh eye this morning and after writing up my first comment here, the answer jumped out to me straight away. the script loacation was still not getting picked up by the custom code area. i tinkered with the src and TaDaaa!!  its working now. Amazing what a fresh pair of eyes can bring to situtation.

 

Anyway, its a great theme on a great platform. looking forward to learning more about it now :)