Metaweblog.axd is 404

Topics: ASP.NET 2.0, Business Logic Layer
Aug 25, 2011 at 10:10 PM

I'm trying to connect Windows Live Writer to my blog but the paths I'm trying are returning 404 errors. 

My blog is at so I've tried and (the site is hosted at go daddy and they mangle the urls and append the /blog because that's the folder I've got BE.N in). 

I have recently changed the domain name from to and have set redirects in the web.config from the old domain name to the new one. Everything else is working fine... just can't post from WLW at the moment. Any ideas?

Aug 27, 2011 at 8:28 AM

Ok it looks like the rewrite rules in my web.config are causing the issue, I commented out the chunk below and was able to post again, both from WLW and the built in tools.  


                <rule name="twsLowerCase">
                    <match url="[A-Z]" ignoreCase="false" />
                    <action type="Redirect" url="{ToLower:{URL}}" />
				<rule name="twsRemoveBlog">
					<match url="(.*)blog(.*)" />
					<action type="Rewrite" url="{R:1}" />
                <rule name="twsRemoveDefault">
                    <match url="(.*)default.aspx$" />
                    <action type="Redirect" url="{R:1}" />
                <rule name="twsRemoveTrailingSlash">
                    <match url="(.*)/$" />
                    <action type="Redirect" url="{R:1}" />
                <rule name="twsCanonicalHostNameRule">
                    <match url="(.*)" />
                        <add input="{HTTP_HOST}" pattern="^www\.the-wombat-speaks\.co\.uk$" negate="true" />
                    <action type="Redirect" url="{R:1}" redirectType="Permanent" />


and when I take them out I can visit /metaweblog.axd but get this:


This XML file does not appear to have any style information associated with it. The document tree is shown below.
Invalid XMLRPC Request. (StartIndex cannot be less than zero. Parameter name: startIndex)

I would like to keep the rewriting though, I need to keep the cannonical host name there because of the change in domain names and the other rules are there to try to standardise the urls that are created so any search engine results are for the 1 version of the page and not split. Currently you can access the homepage at 


Sep 15, 2011 at 7:04 PM

Ok I figured it out the problem is with lowercasing the urls, because Services are case sensitive. Removing that single rule fixes all the problems I've been having:

  • Not being able to connect with Windows Live Writer 
  • The Posts page in Admin doesn't show any posts
  • Various 404 errors 
  • Save failing to do anything on posts
  • etc.

I'm not sure what the best solution is here - probably there's no need to worry about any of the admin pages being lowercase though... my my regex-fu isn't that strong.