This project is read-only.

Cannot remove or edit Widgets

Sep 2, 2011 at 12:42 PM

Hi there,

I have recently migrate my BE 2.5 blog from XML to SQL Server. Since then, I can add the boxes (Linklist, TagCloud, TextBox, Recent Posts, etc,...) but I cannot edit or remove them. I confirm the action in the modal pop-up, but nothing happens.

Thanks in advance.

Sep 6, 2011 at 5:57 PM


I recently dealt with something similar. I have a BE 2.5 installation running on SQL. All widgets worked perfectly in the default theme which I was using. I switched  to a beautiful new Razor theme called AllTuts which you can download from the gallery on

While most of the things on this theme worked, widgets editing/removing stopped working. You could add a widget, but you couldn't edit or remove it just as you describe it. After some javascript debugging I found that in the WidgetContainer.cshtml file the id for the div was set as: id="widget-@(Model.Widget.WidgetId)" when it should have been id="widget@(Model.Widget.WidgetId)" with no dash.

That fixed my issue. However, since you have not given much details, I have no clue if you have the same exact problem.

I just wanted to share it...

Sep 15, 2011 at 9:30 AM


I had exactly the same problem: SQL + AllTuts Theme.. So your solution is also my solution :)!!

Thanks a lot!

Sep 15, 2011 at 1:41 PM

Oh I'm glad!

I already notified the theme author and he promised he would update it.

I'm exploring a fix to the nested comments which it does look it supports it but it does not work. Nested Comments work on your side?

Hopefully I find a solution soon, because I do not want to use another theme...