Need help on new installation

Topics: ASP.NET 2.0
Sep 25, 2011 at 4:16 PM

Frinends, as you can note I'm new to BlogEngine.Net.

I installed the blog in my local machine and it works fine.

The installation on the server (  doesn't save or edit any data.

The blog shows up but data can be manipulated...

How do I fix that?



Sep 26, 2011 at 5:04 PM

Check out this post - it shows how to set up write permissions on godaddy. If still not working, may try to use this checker to verify IIS permissions.

Sep 26, 2011 at 5:13 PM

Hi rtur,


Thank for getting answering my post.

The application is hosted locally , on my development machine, just the database is at godaddy.

When I change the connection string to point to localhost it works fine. If I change to point to godaddy, I can't save data.

If I don't have the app installed at godaddy, does the permissions issue still make sence?

Sep 26, 2011 at 5:22 PM

Godaddy does not allow remote DB access, I ran into it myself and their support told me so. Use local sql express for testing locally then change connection string before deploying to godaddy.

Sep 26, 2011 at 6:08 PM

Well, as long as is not a problem on my end, I can live with that.


Thank you very much for your help.

Sep 29, 2011 at 10:16 PM


I uploaded the site to a new server, on the same provider and still can not save data...

Any ideas??

Sep 30, 2011 at 1:33 AM

What errors are you getting if any? Are you sure you using DB and not XML provider? Any javascript errors? Tell me more :)

Sep 30, 2011 at 3:54 PM

Looks like you have issue with identity columns. PostRowID and PageRowID should be identities and auto-increment on insert, in your provider DB this does not work. If you are using SQL server, try right-click be_Posts table and use "script table as create to new window" to get script used to create table. Compare your local with provider.

Sep 30, 2011 at 8:22 PM

I dropped and re-create the DB and it works now.  thanks