I got error Message 404

Topics: Controls, Themes
Sep 25, 2011 at 9:16 PM

Hi Every Body:

today I uploaded the BlogEngine.web  by unzip its folder and copy all the files to the main folder in my website which its name as my domain name and I did give permission to the App_Data folder to be able to read and write by anonymous user but I still face this problem when I click in Dashboard I got the error page 404 also I got the same error when I clicked into themes link too.

Given the fact that My host sloution its shared on the interent and its support Asp.Net 4.

any help regarding this issue will be appreciated



Sep 28, 2011 at 6:10 AM

Looks like your blog's admin folder is not placed at the right location.

It should be in the root of your website even if you have set up Blog in the a subfolder.

For e.g. if your root is ~/   , then admin folder from BlogEngine.NET directory shoudl be placed in ~/admin

You can refer this article on where to place various folders and files to set up BlogEngine.NET:


Let me know if you need more information.

Sep 28, 2011 at 11:49 AM
Edited Sep 28, 2011 at 11:52 AM

Hi everyone

I have been searching for ages to find a blog solution and this by far looks the best so excellent work.

I however have similar issues to husamalahmadi :(

I have installed version 2.5 into an existing website running on Windows Web Server 2008/IIS7 and the site has been configured to run .NET 4.0.

For ease of installation I have created a subfolder called blogs and put all of the files in there and then configured that folder as an Application to save moving files into the root and keep the blog totally separate.The majority of it seems to be working correctly but when I log in as an administrator I get 404 errors when going to the following admin sections:



Settings -> Themes

I have checked the obvious to make sure the files are physically there (and they are)

I have also tried the solution anil21_22gupta mentioned above but all I got when I went to the blog folder was a heap of random characters. I rechecked the instructions and re merged the config files without any luck so returned to my previous/now current installtion as that was mostly working.

You are able to view the blog and associated problems at http://www.waypointca.co.z/blog/ and the login and password are still the default user admin/admin

Any guideance/assistance you may be able to offer would be greatly appreciated as this has me lost

Many thanks


Sep 28, 2011 at 12:28 PM

Have you copied your ~/Blogs/themes   folder too in ~/themes   ?

There are code snippets in BlogEngine which refer to themes  sometimes in root ~/ and sometimes in ~/Blogs/themes.

You can offcourse change the code to point all of them to ~/Blogs/themes  but it stands the chances of breaking some funcitonality.

So, it is advisable that you copy the themes folder in root too.

Let me know if this solves your error.

Sep 28, 2011 at 9:56 PM

Thanks for the prompt reply.

I did as you suggested and copied the themes file to the ~/ but this has not fixed the 404 errors going to the following pages:



Settings -> Themes

I also checked the urls going to them and they do appear to be pathed correctly into the subfolders eg:


Any other suggestions??





Sep 29, 2011 at 12:14 AM

Hi everybody

Have got it all working and thought I would share the solution in case there was anyone else struggling with it.

I added this attribute to web.config file


in the following part of the config file

<system.webServer>  <modules runAllManagedModulesForAllRequests="true">

Now all of the cshtml files work:

Settings -> Themes

Thanks for everyone's input


Sep 29, 2011 at 5:12 PM

Hi Anile:

I did as you told me and my admin folder under the root of my website as ~/Admin and also ireferr to the artical that posted in your Blog in the following link


so what can I try next, any help appreciated guys



Sep 29, 2011 at 5:47 PM


Did you try the solution which has worked for eb in same thread? Just try it and it may work.

If it does not, then please help me with the BE version that you are using. is it BE 2.5?

If you are not able to see the dashboard but your blog main page is working, then most probably the above solution by eb should be able to solve your issue.

Sep 29, 2011 at 11:45 PM

Hi Again Anil:

I also tried the solution provide by eb but also did not work with me either, at first was just the DASHBOARD, Extensions and Themes which give me this error but right now when I access my main page I got the 404 error and by the way the version that I am using here is BE 2.5?