Fresh Install - Error - web.config Line: 54

Topics: ASP.NET 2.0
Oct 13, 2011 at 3:14 PM
Edited Oct 13, 2011 at 3:17 PM

I have the BLOG folder set as an ASP.NET 2.0 application.  I am not even messing with the SQL version yet...just trying to get the basic version working first.

The default content page for the BLOG application is set to default.aspx

The ASP.NET Machine Account along with the IIS Account both have modify and write access to the App_Data folder.

Thanks for your help!

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized configuration section system.web.extensions.

Source Error:

Server Error in '/BLOG' Application.

Configuration Error


Line 52: 		</behaviors>
Line 53: 	</system.serviceModel>
Line 54: 	<system.web.extensions>
Line 55: 		<scripting>
Line 56: 			<webServices>

Source File: C:\Inetpub\wwwroot\owenimages_com\blog\web.config    Line: 54



Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053

Oct 13, 2011 at 4:21 PM

What version of BE are you trying to use? If it's 2.5 then you have to set your application pool as .NET 4.

Oct 14, 2011 at 6:50 AM

I agree with MDG_King. Looks like you are using BE 2.5 with 2.0 and hence the error.

Oct 14, 2011 at 2:12 PM

Thank you for your help.  That sounds like a darn good guess.  ;)  I am on an old server and will migrate to a new server this weekend that has .NET 4 on it and will try again.  Thanks everyone.  I will update after the move.