Error message when saving widget edits & extremely slow loading

Topics: ASP.NET 2.0
Oct 26, 2011 at 6:38 PM
Edited Oct 26, 2011 at 6:41 PM

I'm getting the following message when I tried to save text edits to a widget on our live blog.  I was able to update the widgets fine yesterday.  Because the blog was loading extremely slow, our network guy created a new .net application pool to replace the .net 2.0 application pool.

 

Any suggestions how I can fix both the slow loading and this new error message?  Apparently all the files in the App_data folder are not in read only mode.

 

I did try to un-check compress WebResource.axd but I got an error message: Could not save settings: Access to the path 'C:\inetpub\wwwroot\Http\KonvergeBlog\App_Data\settings.xml' is denied.

 

Thanks so much in advance!

 

Server Error in '/' Application.

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

 

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

 

Oct 26, 2011 at 6:59 PM
Edited Oct 26, 2011 at 7:00 PM

Could not save settings: Access to the path 'C:\inetpub\wwwroot\Http\KonvergeBlog\App_Data\settings.xml' is denied.

 

This shows that you do not have full access to the app_data folder:

You must have the following rights:

Read

Write

Execute

To check your settings download this checker:

Checker

Upload this folder on your web server.

Then go to www.yourwebsite.com/check

All lights should be green.

This will tell you whats wrong.

I bet its your new app_pool

Also read this post from Rtur

Have a good day,

Brian Davis


Java Blog

Oct 26, 2011 at 7:39 PM

Thanks and yup we did not have all the right permissions on that folder.  Got it working and un-checked compress WebResource.axd in the admin panel.  Running smoothly now :)

Oct 26, 2011 at 8:00 PM
charris wrote:

Thanks and yup we did not have all the right permissions on that folder.  Got it working and un-checked compress WebResource.axd in the admin panel.  Running smoothly now :)

 

Thats great to hear!!

 

Glad it worked for you :)