YouTube video in Blog Post

Topics: Controls
Nov 3, 2011 at 10:44 PM

How would I put a you tube video, with the big image thumbnail, into a page or post?

Here's what I am trying to create: 

http://bahainyc.org/events/activities_for_youth_calendar

Nov 4, 2011 at 12:01 AM

I think this will do it for you:

http://thenetheryfamily.com/myvideos.aspx

Nov 4, 2011 at 12:02 AM

I can help you if you want this:

http://thenetheryfamily.com/myvideos.aspx

Nov 4, 2011 at 12:06 AM
Edited Nov 4, 2011 at 12:07 AM

The easiest way is to click on the Share button under the video on YouTube and then click on the embed button. This will give you the HTML code you need. Copy it and then start a new post. Make sure you click on "use raw HTML editor" and then paste the code. Uncheck the "use raw HTML editor" and then continue writing your post. Simplest way I've found.

Nov 4, 2011 at 12:10 AM

When you edit a page and past in the embed tagged code, it is stripped by the editor though when you save.

Nov 4, 2011 at 12:11 AM
ianvink wrote:

When you edit a page and past in the embed tagged code, it is stripped by the editor though when you save.


Mine's not. Are you sure you're clicking on the "use raw HTML editor" when editing the post?

Nov 4, 2011 at 12:12 AM

Not a post, a page. Pages are where the issue is.

Nov 4, 2011 at 12:18 AM
Edited Nov 4, 2011 at 12:19 AM
ianvink wrote:

Not a post, a page. Pages are where the issue is.

I can't get it to error. I post the embedded code to a new page. Instead of "use raw HTML editor" (because it's not there when creating/editing a page) I just press the HTML button in the TinyMCE editor that's viewable when editing. The video then shows up in the page. What version of BE are you using? Which browser are you editing from?

Nov 4, 2011 at 12:42 AM

See this post.  I think it may be your solution:

http://blogengine.codeplex.com/discussions/246794