Blog Engine 2.5 Error On my host

Nov 19, 2011 at 9:03 AM

Hı I am traying to open my be 2.5 blog on my host but is give error

HTTP Error 404.17 - Not Found

The requested content appears to be script and will not be served by the static file handler.


My host company using iis 7.5 


How can ı Solve this problem ?



May 12, 2013 at 1:15 PM
I know this is old but I found a possible answer when I was upgrading from IIS 6 on a 2003 server to IIS 8 on a 2012 server.

Turns out the Application Development code is not installed by default when you install IIS.

Go to "Server Management"
"Add roles and Features"
"Web Server (IIS)"
"Web Server"
"Application Development"
make sure ASP.NET 4.5 is installed

BlogEngine.NET AppPool should be configured with .NET 4.0, Integrated, you do not need 32-Bit Applications.

Hope that helps!