Blog Absolute Webroot

Dec 16, 2011 at 2:35 PM

I have just installed BlogEngine on my webserver but having some trouble loading the homepage. In development, I can set the Start Page to default.aspx and the absolute webroot automatically picks this up. However, when I navigate to the homepage on my website, I get the following error:

"Server Error in application;

Length cannot be less than zero.

Parameter name: length"

I understand that this may be an issue with the webroot being served an empty length parameter. The "default.aspx" should be used to serve the home page "/" but I don't get anything unless I navigate to "/default.aspx". I'd like some suggestions on how to setup the homepage or webroot to pick up "default.aspx".


Dec 16, 2011 at 5:47 PM

You need to configure default document in IIS. Depending on IIS version procedure is slightly different, here is example for IIS 7. You can also add this to web.config if you don't have access to IIS and your provider does not give you any options.

Dec 16, 2011 at 7:56 PM

I've set up the settings but I'm still getting the same error message. Could this be a problem in the BlogEngine Settings somewhere?

Mar 7, 2012 at 6:01 PM

I have worked on this same issue and not been able to resolve... have you had any luck? Default Document then only creates a 500 error.