js.axd problems

Jan 11, 2012 at 10:38 PM

Hi All, 

I have a new install of on IIS7 - js.axd seems to be having some problem to the effect that all domain.com/js.axd?path=XXX calls take a REALLY long time. 

Looking at my event log I see some socket error timeouts. I suspect that the web server itself is trying to make HTTP requests to URL supplied on Path which is domain.com/WebResource.axd 

My internal network is unable to make requests to internal domains for security reasons (long story) - is there some way to disable this behavior?. 



Jan 12, 2012 at 6:31 AM

I've seen this same problem before ... where making HTTP requests to the same server timeout because of routing issues.

In the BE settings -> Advanced, uncheck the "Compress WebResource.axd" setting, and then Save.

Jan 12, 2012 at 1:22 PM

Thanks you sir. That was a great help. Worked like a charm.