Can't change "Name of the Blog"

Jan 20, 2012 at 8:46 PM

I've got the blog running but I can't get it to retain the "Name of the Blog" or description setting under Basic Settings for the Settings tab.  I tried to enable the write permissions on the App_Data folder but that won't persist either.  I've even tried unloading the project project in VWD 2010.  Changing the read only attributes to the App_Data folder, with all files, subfiles, and subfolders.  I then reload the project and try to change the "Name of the Blog" setting again but it doesn't persist when the save button is clicked.  I'm logged on my pc and in the BlogEngine project as Administrator.

There are two things very strange that I don't understand.  I've been able to do other administrator things like add new blogs to the blogroll and create pages but not change the Name of the blog and it's description.   I also don't understand why I can make these changes and they persist since the unchecking the read only attribute on the App_Data folder doesn't persist.

Why won't the settings changed like "Name of the Blog" persist but the other changes like adding pages and blog roll modifications do?

Why doesn't the unchecked read only attribute in the OS's file system persist?  I clicked apply and chose all folders, files, subfolders etc. and it does it but when I go back to the same property it's rechecked.

Coordinator
Jan 20, 2012 at 9:30 PM

I'm a bit confused with your setup by creating project and dropping files etc. Generally, you download source code and click solution file (BlogEngine.sln). It should open it in VWD and then you just set BlogEngine.Net as startup project and run it, should be no issues.

Jan 20, 2012 at 10:06 PM
Edited Jan 20, 2012 at 11:45 PM

There is no solution file in the BlogEngine.Web folder that was created when unzipping it.  I downloaded the 2.5 web version, not source version.  I created a new website project in VWD 2010.  I then pasted the files from the download into the directory for my newly created website project. Included files into the project. 

It ran first build this way.  It just created it's own solution file.  All of the downloaded project files are there, as far as I can tell.  It seems to run fine in general and accept the changes I made to the Blog roll, new pages, and new blog entries.  

The inability to alter the settings is baffling though.  I was starting to debug it and set break points.  I also changed the values of the Name of the Blog and Description directly in the XML files, located at App_Data/settings.xml but it didn't reflect these new values when the project ran.  It only had the original defaults when it ran.  I went back and confirmed that the xml value was still the new value I changed it to but the page showed the old one when I ran the project.  So, it retained the new value when manually entered in the XML file but showed the old value when I ran the project. I even tried closing and restarting the browser to be sure it wasn't showing a cached version.  This doesn't make sense either.

Maybe I should start over the way you mention.  But, my issues still don't make sense.  It seems like they will only repeat.  Do you know how I can address them if they repeat?

Jan 21, 2012 at 1:01 AM

As Rtur says, there is definitely a .SLN file in the source code download (in the root of the BlogEngine folder.)  Because of the strange setup procedure described, I'm in the camp that you reinstall.  My thinking is that your installation may be using another location that the /app_data directory you think it is.  

Good luck,
Dave

 

Jan 21, 2012 at 3:24 AM
Edited Jan 21, 2012 at 3:28 AM

I appreciate the help.  I don't mean to seem too hard headed, but the zipped folder I downloaded "BlogEngine2.5(web).zip" doesn't have a .SLN file in it.  I did a search on the extracted folder with *.sln and no file was found.  I even unzipped the original download again and searched that one the same way (with *.sln) and no SLN file was found.  Both of these instances of the unzipped original files were searched before I put them in a project or did anything to them.  They were both 100% in their original state.  So reinstallation should only produce the sme results.  So would downloading it again.

The other thing that doesn't make sense is that I can write to App_Data/blogroll.xml through the control panel but not App_Data/settings.xml.  I also had the issue of the readonly attribute defaulting back to the undetermined state, a blue box, even after I applied everything the way I should've.   I finally got around this by setting this attribute at the command line as admin.  I could then only change the App_Data/settings.xml manually, not with the control panel.  This enabled me to finally change the stuff in the header of the masterpage. 

There seems to be something wrong with the code somewhere.  It doesn't make sense to be able to write to one xml file and not another in the same directory.

The .SLN file is created when the project is built.  I just created a fresh website project, standard vwd 2010 basic project, to test the theory that the .SLN file isn't the issue.  I deleted the .SLN file after the first time it built and ran.  I then re built it and a new .SLN file appeared.  It created a new one as part of the build process.

I hope I'm explaining this well.  I want to get this working the way it should.  I'm really excited about this product.

Are you guys thinking of the BlogEngine2.5(source) download and not the BlogEngine2.5(web)?

Do my explanations make sense? 

On the download page it says the code was updated a couple weeks ago.  I'm wondering if something was mistakenly changed.  I'm grabbing at straws because nothing wlse makes sense.

Coordinator
Jan 21, 2012 at 4:11 AM

"BlogEngine2.5(web)" is a web deployment project, not a source code.

Source code is in the "BlogEngine.NET 2.5 (source)" - this is the one you should use if you want build project from source in VWD 2010.

If you want just use BE as is, then you go with "BlogEngine2.5(web)" and follow this procedure to deploy it to web server.

Jan 21, 2012 at 3:24 PM

Thanks for the clarification.  I misunderstood things slightly.  I thought it would be ok to work with the (web) version as long as I didn't want to dig into the dll and modify that source code.  I'll give the (source) version a try.

Feb 3, 2012 at 2:59 PM

Hey Codeplexer,

Did you manage to change the "Settings" using BlogEngine2.5(web). I have the exact same problem, for no matter what I do, "Name of the Bog" remains the same. I can Add blogs and pages and posts, etc. But I can't change those "Settings".

Any help appreciated (I am going to delve into the Source Code also).