Configuration Error - XmlBlogProvider

Jun 2, 2008 at 12:03 AM

Hello.
I have following error message when I try to open my blog page.
Since I'm novice for .net application, I have no idea where to look in.
It works fine when I tested on my local PC with IIS5.01, but when I uploaded to
Network Solution's webhosting, I see this error message.
Can anybody help me?

Regards,
Michele


Server Error in '/' Application.


Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

Line 9:  
Line 10:   <BlogEngine>
Line 11: <blogProvider defaultProvider="XmlBlogProvider">Line 12:       <providers>
Line 13:         <add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>

Source File: E:\0\1\56\39\1545202\user\1663651\htdocs\blogengine\web.config    Line: 11

Jun 2, 2008 at 1:51 AM
Michele,
There are two choices to resolve this error:

1. The error is caused by the BlogEngine.NET installation in the server that is not configured as a web application. Usually we do this if we just copy BlogEngine.NET into a sub directory under our main directory. If your web hosting provider can be contacted to configure the virtual directory as a web application, this is the simplest solution to do.

2. Some tags in the web.config are configured with attribute value allowDefinition='MachineToApplication'. These tags cannot be placed in the web.config that is not directly contained within root web application. If you have enough time and patience, you could move these tags from BlogEngine.NET web config to root' web config. But I really don't recommend this solution. It is error-prone and not maintainable.

Regards,
Agus Suhanto
http://suhanto.com
Jun 2, 2008 at 2:36 AM
Dear Agus
Thank you for your quick reply.

When I tested on my local PC with IIS5, I configured as a web application at
IIS > BlogEngine > Properties > Directory Tab > Application Settings then select BlogEngine as Application name.

>1. The error is caused by the BlogEngine.NET installation in the server that is not configured as a web application. Usually we do this if
>we just copy BlogEngine.NET into a sub directory under our main directory. If your web hosting provider can be contacted to
>configure the virtual directory as a web application, this is the simplest solution to do.


So, as you said, even I configured as above, it's not recognized as web application at hosting server?
I will contact to hosting service and see if they can do this configuration.

Regards,
Michele
Jun 10, 2008 at 9:26 PM
Oh, please also don't forget to check your website's application pool. If you run under IIS 7, please configure your web application to use Classic .NET AppPool instead of DefaultAppPool.

Regards,
Agus Suhanto