Does V 1.4 only works with High trust or above????

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Jul 13, 2008 at 6:15 AM
My blog runs on gadaddy shared hosting and it allows me only to use medium trust

After upgrading to v 1.4 I had this exception
Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Net.WebPermission, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Please Help me, It happens in medium trust zones when you try to add a widget to the page.

Jul 14, 2008 at 7:12 AM
Try to remove Blogroll widget on "App_Data/datastore/widgets/be_WIDGET_ZONE.xml"

I had a same problem.
An error occurred while reading "system.web/compilation section" on the web.config.
I applied a interim patch.

Utils.cs Line370: CompilationSection s = null;

And I applied other patches of HttpWebRequest.
ex) Blogroll.cs Line201: //item.Request = (HttpWebRequest)WebRequest.Create(feedUrl);