Themes issue

Topics: ASP.NET 2.0, Themes
Jul 21, 2008 at 1:13 AM
Edited Jul 21, 2008 at 1:16 AM
Hello all,

I want to give the a spin, but i'm having a problem straight out the box.  I put all the files in a "blog" folder in the root directory.  I followed the steps with permissions and created an application.  When I try to run it the first time, I'm getting a configuration error stating it cant find a them.  My site is based on using a "pink" theme.  it seems the blog is making reference to the web.config in the root directory and not its own.  It says it cant find the theme, but I know it's there and it works because my entire site is still pink.  What to do?


Server Error in '/blog' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Theme 'Pink' cannot be found in the application or global theme directories.

Source Error:

Line 8:  	</connectionStrings>
Line 9:  	<system.web>
Line 10: <pages styleSheetTheme="Pink"/>
Line 11: <customErrors mode="Off"/> Line 12: <compilation debug="true"/>

Source File: c:\inetpub\wwwroot\web.config    Line: 10

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
Jul 21, 2008 at 1:15 AM
Also, I noticed when looking at the code, the pages (such as default) are not attached to a master page.  did I get a bad download?
Jul 21, 2008 at 2:41 AM
Edited Jul 21, 2008 at 2:42 AM
Hi pcdebb!

For your first issue of the <pages stylesheetTheme="Pink"... /> there is no styleSheetTheme setting in BlogEngine.NET. You might not have created your web application correctly.  Also, the location of this particular web.config is c:\inetpub\wwwroot.  The best way to create your web application if in XP, for instance, is to bring up the IIS Manager, then add a virtual directory to the location of your BlogEngine.Web directory and set it as an application.

As to the master page issue, if you look at, say, the default.aspx.cs codebehind file, it's derived from a file in the BlogEngine.Core library called BlogBasePage.cs.  Since all BE.NET pages use the same Master page, it is set there.


Jul 21, 2008 at 3:18 AM

I went into IIS and set the "blog" folder as an application already.  The existing website uses the pink theme and that setting is in the root web.config file.  I dont understand why the page nested in c:\inetpub\wwwroot\blog is reading the web.confing at the wwwroot location?  I would think it would read the web.config file located in the /blog folder.  I googled for almost two hours before even posting here because I wanted to do my best to find the answer on my own first, and of course I failed.

I've tried so many options I dont know what else to do.
Jul 21, 2008 at 11:52 AM

Sorry for the trouble you're having.  We'll get it.

So you're using XP?  If so, then you went into IIS, then right-click on the root site and selected "Add virtual directory?"  Then enter "blog" as the alias and selected the BE.Web folder.

Jan 11, 2015 at 1:56 AM
Edited Jan 11, 2015 at 1:58 AM
I am having the same problem on a shared host and a local iis on win 7
The existing site has a theme with master pages and all and works fine

Created a folder, made it an application and copied a working BE3 install

get the same error
Theme 'wabs' cannot be found in the application or global theme directories

created a new site and pointed it to the same folder and it works

when BE3 is made a sub application in an existing website it tries to inherit the theme from the main site instead of using the BE3 theme
Jan 13, 2015 at 5:30 PM
Fixed, I added [theme=""] to the pages tag [ <pages theme="" ..... > ] in the blog app folder to stop the blog webconfig from inheriting the parent website webconfig