Memory Consumption

Topics: ASP.NET 2.0
Apr 2, 2012 at 3:57 PM

We are running v 2.0 with about 20 blog instances/sites within one app pool.  The app pool just keeps consuming memory and lots of it until it recycles (about once per minute).

We've tried splitting out the instances into more app pools but same thing happens.  Seems like a memory leak somewhere.  However, it looks like v 2.0 was supposed to stop that from happening.

Any other ideas/suggestions on what it might be?  We are at a loss and have spent way too much time troubleshooting as it is.  If we can't find a resolution we won't be able to continue using dotnetblogengine as it doesn't allow us to scale at all:(

Help please!!!


Kevin | InteractRV

Coordinator
Apr 2, 2012 at 4:26 PM

There are few discussions about this issue you might look into:

http://blogengine.codeplex.com/discussions/233966
http://blogengine.codeplex.com/discussions/56170
http://blogengine.codeplex.com/discussions/41287

Apr 2, 2012 at 4:53 PM

Yep, looked at all those. Non seem to apply.

Apr 4, 2012 at 6:05 AM

I am having this issue too on a shared web hosting environment.  But, only have 1 blog per app_pool

 

The host I am using only allows up to 100mb for the app_pool before it recycles the app_pool meaning it stops the app_pool giving the website an

500 Server error which causes it to go down until you restart the app_pool.

 

I am using BE 2.5.0.15

 

The website have over 100 posts using xml for the database.

 

The website I am talking about is this one:

 

http://programmingsolution.net/

 

Some times my other sites go down too

 

like this one

 

http://www.kbdavis07.info

 

Both are using xml databases

 

Thanks,

 

Brian Davis