Problems with the admin page

Topics: ASP.NET 2.0, Business Logic Layer
Apr 17, 2012 at 8:12 PM

Hi Folks.

I'm having problems with my BE 2.5. I can't edit the settings or view the Posts and pages???

I have already given all permissions for the App_Data folder but nothing works.

Apr 17, 2012 at 8:44 PM
mafelis wrote:

Hi Folks.

I'm having problems with my BE 2.5. I can't edit the settings or view the Posts and pages???

I have already given all permissions for the App_Data folder but nothing works.

Help me! 

Apr 17, 2012 at 8:47 PM

Help Me?

Coordinator
Apr 17, 2012 at 8:55 PM

Is this fresh install or upgrade? Did you download release (web) version or run from source code? Does firebug or alike show any script errors? More you tell easier it is to figure out what your issue is. "help me" is not very specific :)

Apr 17, 2012 at 9:34 PM
Edited Apr 17, 2012 at 9:36 PM

Is Install. the version is 2.5 is a release. not source code.  the Google Chrome Script Console shows:

  1. Uncaught TypeError: Object [object Object] has no method 'validate'
    1. (anonymous function)Main.aspx:93
    2. jQuery.Callbacks.firejs.axd:1046
    3. jQuery.Callbacks.self.fireWithjs.axd:1164
    4. jQuery.extend.readyjs.axd:435
    5. DOMContentLoaded

I don't know if this helps. but the part of settings I can't edit them. and on Posts, pages and Blog appears empty? without anything.

Coordinator
Apr 17, 2012 at 10:45 PM

Sometimes when download/upload files got corrupted. First make sure you have ~/scripts/jquery.validate.min.js file because it seems to be complaining about missing validation. May be try to pull it again and run locally to see if you get these errors.

Apr 18, 2012 at 6:30 PM

The problem is on line:

            var frm = document.forms.aspnetForm;
            $(frm).validate({
                onsubmit: false
            });
the Jquery.validate.min is not working?

Apr 18, 2012 at 7:57 PM

Hi. i try include the Jquery.valide library source code direct in admin.master head. and the error (no method 'validate') is solved. but

the Chrome Console displays:

Failed to load resource: the server responded with a status of 500 (Internal Server Error) - Main.aspx/Save

on click of save button.

Coordinator
Apr 18, 2012 at 8:37 PM

You should not manually include anything if you do clean install, this code is tested and should work as is. All scripts included in /scripts folder will be loaded by BE, you might need to clear browser cache and maybe restart IIS if script not added to the page, but including it manually can mess up things as this script dependent on jQuery and must be added after it. If you still have server-side error, set "custom errors" tag in web.config to "off" so that errors will show up on the page and you can identify what's wrong on the back-end.

Apr 19, 2012 at 6:11 PM
Edited Apr 19, 2012 at 6:15 PM

 

I do not know. I just know that this is really disturbing me and stopped 3 days solving a problem that was not to be my.

 

As Head of Page appears to me that is linked jQuery.Validate:

<script type="text/javascript" src="/ClicWebsite/js.axd?path=%2fClicWebsite%2fScripts%2fjquery.validate.min.js"></script>

 

But does not work. will include that in the solution was admin.master:
<script src="<%=Blog.CurrentInstance.AbsoluteWebRoot %>Scripts/jquery.validate.min.js"></script>

 

the error was resolved. but when I click save, that error 500 is generated??


I can not just erase everything and start again many pages have been customized.

 

  <customErrors mode="Off" defaultRedirect="~/error.aspx" redirectMode="ResponseRewrite" >      <error statusCode="404" redirect="~/error404.aspx"/>    </customErrors>

Without any additional response?

Apr 19, 2012 at 10:07 PM

Any Response?