This project is read-only.

Browser compatibility in Admin module

Topics: Business Logic Layer
Jun 25, 2012 at 1:42 PM
Edited Jun 25, 2012 at 1:45 PM

I created a sub-blog from my primary blog using the admin modules feature for this. It all works fine as long as I stay in my Chrome browser but when I switch to IE the Admin pages are empty except from the Dashboard. I can create everything but they will not display in IE.  It is possible though from the blog-pages to click edit under a post and edit it from there. 

Switching back to Chrome all records including the ones created in IE are shown and editable from the admin pages.

It is a script error in IE:

Webpage error details
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB7.3; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)Timestamp: Mon, 25 Jun 2012 12:39:20 UTC

Message: Exception thrown and not caught Line: 16 Char: 38989 Code: 0 URI:

Unfortunately I cannot force all my editors to use Chrome.

The BE is ver.

Any way to corect this? Thanks

Jun 26, 2012 at 5:42 AM
Edited Jun 26, 2012 at 5:45 AM

For some bizarre reason, older IE does not like localized "delete" in the templates.

So if you go over templates in /Templates folder changing from {BlogAdmin.i18n.delete} to just "Delete" (no quotes), all should work in IE < 9.

I'll take closer look tomorrow why it is so, doesn't make a whole lot sense as variable clearly exists and no issues with other browsers.

I'm guessing ".delete" is a root cause, it might have special meaning for some parser.

p.s. you'll have to clear browser cache after making change (tools/internet options/browsing history/delete/check temp internet files)

Jun 26, 2012 at 9:55 AM

Thank you for the answer. 

I tried it but it didn't help. Another strange part is that some pages work and others not. For Roles everything works fine but for Users not. I ran the pages in debug mode with the build in tool in IE and all the pages that has script errors stops with a synthaxerror at the finally statement at the red curly parenthesis: 

function(t,i){if(!f&&!n&&!u){i=i||[],u=1;try{while(r[0])r.shift().apply(t,i)}finally{n=[t,i],u=0}}return this},resolve:

I am not very good at this debugging feature but it looks like som function is looping through several functions. The variable t has an URL value of "/admin/Users/Users.aspx/GetUsers" (Roles.aspx/GetRoles on roles page where it works).

Hope this helps.


Jun 26, 2012 at 3:26 PM
Edited Jun 26, 2012 at 3:34 PM

The difference between roles showing up while users don't was my starting point, but it was just because roles do not pass any JSON data when calling AJAX, so not really helpful. The error in jQuery is when it is trying to parse data. My precise steps were:

1. Upgrade to latest jQuery to see if it helps; it didn't.

2. Change jQuery to not minimized version for debugging and set break-point on error. Locals showed that it breaks while processing #content object.

3. Rename #content in javascript and template to check if this is a name conflict. Nope.

4. Simplify template (/templates/users.htm). At first I just left this:


<div class="info">


It worked fine. So clearly error related to the template. Narrowing it down showed that removing "{BlogAdmin.i18n.delete}" element is enough to make it work.

5. Did it for another template (/templates/pages.htm) and it worked just fine. So right now on my test site users and pages work fine in IE7 and IE8, while other pages that have "{BlogAdmin.i18n.delete}" in it keep throwing javascript error.

I'll probably have to rename "delete" variable in localization code to something else to fix it and then push updated code to repository. Will try to do it hopefully later tonight.


-- looks like I could've minimize it to one step: checking comment for this issue. :)

Jun 26, 2012 at 5:55 PM

Thanks again.

The issue you link to solves the proplem...kind of. Changing the delete to "doDelete" of course makes the text disappear though.

Removing BlogAdmin.i18n. makes the chrome browser stop working, so all in all i have changed the BlogAdmin.i18n.delete to BlogAdmin.i18n.doDelete in the templates and it works in Chrome and IE 8...thanks a lot :-)

Sep 30, 2012 at 5:48 PM


Any latest news on the workaround?  I'm using IE 9 and had the same issue.  Changing to DoDelete works except that I still get an error when trying to save a post!