This project is read-only.

Using ASP.Net Members and Roles

Oct 3, 2008 at 6:59 PM
Edited Oct 3, 2008 at 7:00 PM
Hello all.. I just installed v1.4.5 on my site and everything seems to be working well. However, I wanted to have the blog site use my user names and logins.
So for the three providers.. If I set it to use the DBBlogProvider(NoProblem)..It is when I switch to the SQLProvider that it gives me no response on the login..When I try to log on, lets say with Admin and Admin, it says that the login atempt was unsuccessful. 

I also went into the SQL management to make sure that the user in the connection string has access to the asp tables.
Here is a short little video describing how to set this up. Although, I believe he is using a slighty ealier version than the current. Don't know if that really matters here.
Just in case, here are the two sections in the web.config that I made changes to. Basically swapping out the default providers and that should have done the trick according to the demo.
Any help is greatly appreciated,
    <membership defaultProvider="SqlMembershipProvider">
    <add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed"/>
    <add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
    <add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine"/>
    <roleManager defaultProvider="SqlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES">
    <add name="SqlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider"/>
    <add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
    <add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>