Creating Themes

Topics: ASP.NET 2.0, Themes
Oct 13, 2008 at 12:45 AM
I have written about this before, but have the same problem no mater where it goes. I checked to see which version of net framework is on my machine and it is 3.5. However, when I check the errors on this page it clearly says I have 2.0 how do I fix this?

Server Error in '/' Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS1513: } expected

Source Error:

Line 916:        }
Line 917:
Line 918: [System.Diagnostics.DebuggerNonUserCodeAttribute()]
Line 919: private void @__BuildControlTree(themes_thiesland_site_master @__ctrl) {
Line 920: System.Web.UI.IParserAccessor @__parser = ((System.Web.UI.IParserAccessor)(@__ctrl));

Source File: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\ddc04a1e\714d1d2\App_Web_site.master.55665584.yvjwbeue.0.cs    Line: 918

Oct 13, 2008 at 8:39 PM
For simplicity's sake, 3.5 runs on top of 2.0 so it will always say 2.0 in the debugger or error messages.
Oct 19, 2008 at 11:00 PM
Ok! But I still do not understand why I am still receiving bug problems for my theme creations. My real question is what is [System.Diagnostics.DeubuggerNonUserCodeAttribute ()]
I can usually wade my way through these things, but this one is a little confusing.