Extensions load crash...

Oct 16, 2008 at 9:24 PM
I have five or six versions of BE 1.4.5.0 running on IIS6 servers, plus a few running on Vista/IIS for test purposes. They're all fine except the one I have running on SQLserver. It's been there since the early days, but I always have trouble with the SQL install, which is one reason I left all the others on XML.

My latest problem is that the extensions don't work on this version... if I restart the server I get a crash (I have a dump graphic):

Exception Detail: [...[ Root element is missing.

   \App_Code\ExtensionNamaser\Manager.cs line 23
  ex = (ManagedExtension)serializer.Deserialize(reader);

Anyone got any ideas? Further down I have "there is an error in XML document", so I guess there's some XML somwhere which lists the extensions... but this is a SQL instance.

Is anyone actually using this with a SQL back end, and if you are, do you have any suggestions as to how I may fix this problem? What's it trying to read from XML exactly - a list of extensions or someting?

Alternatively, is there any way I can convert this blog back to xml without losing all the contents? What with the upgrade hassles and all I'm thinking that the hassle outweighs the benefits...

Oct 16, 2008 at 9:49 PM
Well I think my version of 1.4.5.0 has been comment stripped as it's not exactly well documented in there. I found the offending thing and made it catch it's own exception, based on the fact that if you look at it, it can sometimes return nothing useful anyway. And that seemed to allow the extensions to load. So that appears to be a hack which maybe works.
Nov 4, 2009 at 4:22 PM
Edited Nov 4, 2009 at 4:22 PM

I am suddenly experiencing this same issue today. As far as I'm aware, nothing changed on the website.

I AM using xml as my storage (as opposed to SQL) - - but the cause of the error itself remains a mystery.

Anyone have a resolution to this?